Usb usb2-port 3 cannot enable. maybe the usb cable is bad?

Hi i was working on UART followed as per this link
But it didn’t work and after reboot Mouse and keyboard not working.


Are you talking about that broken type C firmware board as the topic you filed yesterday?

Hi @WayneWWW ,
No its not that AGX.
Today I was working on a different AGX.
I was using UART but I wasn’t able to send or recieve any data so I reboted the AGX and this happened?
these are the commands I used

$ systemctl stop nvgetty
$ systemctl disable nvgetty
$ udevadm trigger 

Please Help to fix this Xavier.
Can you please also let me know how to fix the other two AGX which I mentioned yesterday in this thread

If possible Can we have a call through Google meet?

  1. We are still checking if there is any fix for that issue. Please be patient.

  2. We don’t provide any call service here. What you should do is provide the correct log.

1 Like

Hi @WayneWWW ,
As per our knowledge we have provided the correct logs so far, if you need any further we will be happy to provide the same.

You didn’t provide any log so far… what are you talking about …?

Where is your dmesg??? If this new issue is different from that old topic, then you need to share the new log…

Hi @WayneWWW ,
I was talking about the logs which I provided you yesterday Regarding the two Xaviers in this Thread

I took the dmesg through SSH for this Xavier.
I have attached it here
dmesg_uart.log (76.0 KB)

Do you have any device connected on your USB/eSATA port?

If so, could you change it to other device and see if you will see same issue?

Also, if you remove the device and connect nothing, will you see the same issue?

Hi @WayneWWW ,

  1. There are no other devices connected in the USB port other than the Keyboard mous.
  2. I connected a media device and the same happened.
    3.If there are no device there is a difference in the Log.
    I have attached the two logs below for your reference.
    Kindly have a look.
    demsg_uart_no_device.log (69.6 KB)
    dmesg_uart_media_device.log (70.9 KB)

Please reflash with pure jetpack to make sure this is software or hardware issue.

1 Like

Hi @WayneWWW ,
We just flashed the Xavier and found out its working properly after flash.
Thank you @WayneWWW .
Please let me know about the other issues(from the other two Xaviers) once you find out the solution.


Could you recall what is the exact steps that you tried on the board to hit this issue?

Hi @WayneWWW ,
I cloned the code from this Git source GitHub - JetsonHacksNano/UARTDemo: UART Demo Code

Then I complied and tried the code but was not able to send or receive data in UART
Then I tried the following command.

    $ systemctl stop nvgetty
    $ systemctl disable nvgetty
    $ udevadm trigger

    # You may want to reboot instead

then I compiled and ran the code and wasn’t able to find any difference so i rebooted the AGX and then ended up with the issue.

What is the purpose of using this tool? You already knew how to dump uart log from your board yesterday.

Also, are you really sure “ttyTHS1” on Xavier AGX is the port you want to use?

Please be aware that Xavier AGX is not like NX which says their carrier board is compatible with each other.

Hi @WayneWWW ,
I used it for communicating with an external device,
I would need to do that port since I am using the uart_pins(UART1_TX,UART2_RX) .
Is there any-other way other than using “ttyTHS1”?

This is not related to original question. Please file a new topic.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.