Usb wifi dongle not working AGX xavier dev kit. Please help with getting "usb" wifi dongle

Ref: Usb wifi dongle not working. Compatible USB wifi dongle for Xavier?

Hello,

I have multiple robots with xavier on them. I need wifi connectivity on them and I have tried this product and it worked.

But I need something which easy to plug to a particular xavier via USB and disconnect when not needed so that I can use the same dongle on another robot. I tried this blueshadows usb dongle, but cannot get it to working.

here is the link to the provided drivers with the dongle. I am okay with buying another kind of usb wifi dongle if needed.

Please guide to a direction or help with this particular dongle. Thank you

Please share us the dmesg with your device plugged.

dmesg.log (76.8 KB) Hello @WayneWWW
PFA dmesg.log text file and a screenshot as well.

Thank you

Hi db10111,

How many wifi device do you connect on your board? I see you have i8265 card on it and you plug in the wifi dongle later. Is that correct?

Does this blueshadows card directly connect to usb type A port? Or it has went through some adapter?

Could you also share the result of “lsusb”?

hi @WayneWWW

For the real application I will have only one Blueshadows dongle. I added another one temporarily so that we can continue working on it till we can get the usb dongle wifi working.

I use the type C port on the usb as in the picture below and use a type C to type A adapter cable that comes with the AGX xavier.

output of lsusb with USB dongle plugged in:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 046d:0825 Logitech, Inc. Webcam C270
Bus 001 Device 007: ID 1c4f:0016 SiGma Micro
Bus 001 Device 006: ID 046d:c534 Logitech, Inc. Unifying Receiver
Bus 001 Device 004: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 001 Device 003: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter
Bus 001 Device 002: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 001 Device 009: ID 0bda:b812 Realtek Semiconductor Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Looks like the usb detects the dongle, thus the problem may be in Realtek driver or something else.

What is the result of below command?

sudo rfkill list

0: bluedroid_pm: Bluetooth
Soft blocked: yes
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
4: phy3: Wireless LAN
Soft blocked: no
Hard blocked: no

  1. Does “lsmod” command show the rtl88x2bu driver?

  2. Do you see wlan1 in ubuntu GUI?

rtl8822bu 3697509 0

yes. It is grayed and says disconnected.

hi @WayneWWW

it started working now. I don’t know what happened, but really sorry for the trouble and I am thankful the help. I hope the debug commands will help others too.

Do you restart or do something else?

Would you mind sharing the latest dmesg for other user to take as a reference?

yes, i did a restart. But I have tried that before also and it did not work then. My l4t is

R32 (release), REVISION: 4.4, GCID: 23942405, BOARD: t186ref, EABI: aarch64, DATE: Fri Oct 16 19:37:08 UTC 2020

PFA working dmesg log. dmesg_working_bot_only_one_blueshadows_usb_wifi_device.log (92.0 KB)

1 Like