USB3 Issues with ZED camera


I’m trying to connect the ZED 3D camera to the Jetson Nano. It seems that the camera is recognized as a USB2 device which limits the resolution of the camera. Any advice how to solve this?

So far, I’ve tried to connect the camera directly and through a powered USB hub but without any success.


Does it work if you re-plug the camera? See if it can be SuperSpeed in re-enumeration.

For reference, please share your release version ($ head -1 /etc/nv_tegra_release)

Thanks for the quick response! I’ve tried repluggng the camera but nothing seems to work. It is always recognized as a USB2 (480M) on the lsusb list. I used the latest Jetosn image available on the Nvidia website.

Could you try other cables. We have ZED camera and do not observe the issue.

Don’t see ZED 3D on the website, probably you use ZED 2 or ZED 2i.

If there is a HUB involved, try without the HUB, and also with a different HUB. You might also consider posting the actual “lsusb -t” output since it would indicate if a USB3 root_hub is present.

It turns out that the camera cable is faulty, switched to a different ZED camera and everything works.
Thanks for all the help!