USD export ignores units setting

From the current release, Isaac Sim uses meters as units, not centimeters. I want to use 1m/unit in all my Isaac Sim scenes, but when I export USD from Maya, the unit is always cm. The connector seems to ignore that I have set units to meters in Maya. See below for the beginning of the exported USD. I would like the following:

  1. The connector should respect the unit settings in Maya
  2. If this is not yet implemented, I would like a workaround so I have all assets in my Isaac Sim scene with the correct scaling on the prim level.

Thanks for any help!

#usda 1.0
defaultPrim = “World”
metersPerUnit = 0.01
upAxis = “Z”

Hello @bruno.vetter! I have created a dev ticket for the team to look into this. I appreciate you letting us know about this issue! (Internal Ticket number: OM-56654: USD export ignores units setting)