Use Intel® RealSense™ D435 Series Depth Camera on Nano

Hi All:
I am new to Jetson Nano, and I want to use Intel® RealSense™ D435 Series Depth Camera on Nano like kaya, but i can not install librealsense2-dkms, is there anything like buildLibrealsense2TX( Or should I build librealsense from source? Would you give me some suggestion?

Just build librealsense2 from source and it should work.

You don’t need the jetsonhacks version anymore.

I built the legacy librealsense repo a month ago and got my R200 camera working without any issues.

Also, make sure you use the 5v barrel connector for the power. Mine shut down frequently with the USB power supply when I was trying to use my R200 camera.

Thank you very much. I will try it.

It works. Thanks!

I am following the instructions from on a Jetson Nano trying to install realsense on it.

However the step named “4.Build and apply patched kernel modules for:” is failing during the command

0 upgraded, 0 newly installed, 0 to remove and 303 not upgraded.
Package required libusb-1.0-0-dev:  - found
Package required libssl-dev:  - found
Unsupported kernel version 4.9.140-tegra . The patches are maintained for Ubuntu Bionic LTS with kernel 4.15 only

Can you please explain how you worked around this issue ?

I don’t think you need to worry about the kernel patches. Just build the librealsense repo and it should work.

Thanks @Maghoumi for clearing it up. Just building the lib-realsense worked. I am now able to use realsense-viewer. Kudos for the help !!!

Sure no problem :)

@Maghoumi Hello,I have installed SDK2.0 successfully today
But when I execute realsense-viewer,it can’t get my R200,
but I am new to Jeston Nano,
Can you help me to fix it

@ira2821420 s not clear, we are mixing r200 librealsense sdk (legacy) and d4xx and t2xx that use librealsense2. if you instaled librealsense2 wont run you ra2821420 r200

@Maghoumi if you have runing r200 your are not using the librealsense2 that is needed for the d435 of the title.

R200 need a UVC module driver modified and d435 kernel over 4.10.

I do not think anyone of them can be installed just compiling the source code. for the r200 there is a test in the github site

I am trying to use RealSense 435i with Nano - my kernel is 4.9.140-tegra

I tried both instructions on JetsonHacks and “just build” it

Build is OK, I see /device/video0/1/2, lsusb shows Intel, I am using sudo, I have good power.

Camera works with Windows and Intel tools.

On Nano realsense viewer cannot detect the camera - same with some of the examples.

Any hints what might be wrong? Any additional config to do?

Hello @ivostoy, one of the reasons not to recognize the d4xx realsense sensor is the outdated firmeware.

I upgraded mine by the following tutorial, and everything worked fine.

I have a question, I simply compile the library, and everything worked fine, but there is a delay. Does it work better if I change the kernel, according to the following link?

With the Nano, I cannot get the DFU install commands to cooperate. And, #1, I wound up with a “realsense-” in the sources.list. #2, getting the keyserver code to install also breaks, even if I type it in manually. So maybe Intel’s “script” for the updating is not exactly correct for the Nano. Afraid to try it on the desktop, running Debian 9 (stretch.)

I still don’t know the details of the connection. I also had problems connecting. Could you tell me more about it?

try to run in another environment, it works both in linux and Windows.

Updating on any system, gets saved in RealSense, and should work properly on the nano.

it took me a while to realize that it was necessary to upgrade to run on ubuntu. maybe the new realsenses are up to date, but worth a try.

The very first time I ran realsense-viewer on the Nano, it popped up a small window that said the D435 has a firmware update available. Been trying to get that to happen ever since. It -wants- an Ubuntu 16.04 environment and while I have one on an nvme drive in the host, I stupidly dropped the teeny tiny black screw into the carpet and still haven’t found it. So, I was trying it on the Nano and on the Linux Debian 9 (stretch) desktop. If there is a Windows version of DFU, I’ve not found a reference.