Validate Encoding/Decoding up to 30 streams

Hello, I found this video on the Xavier’s page https://youtu.be/vuFo7TBisbI

I want to verify this performance on my Xavier, where are these videos/sample applications located?

thanks,

Keith

Hi,
Please download DeepStream 3.0 for Jetson and try:

Please note that it is based on r31.1

Hi,
I’m wondering how is it possible to “pre-process 1850MP/s, perform inferencing with ResNet-based detection, and visualize each frame in just over 1 millisecond” on Jetson Xavier,
if inferencing even single 300x300 image with, say, SSD+MobileNet and TensorRT takes 10-20ms?
Thanks.

Hi,
In DS 3.0, we demonstrate 4 720p30 decoding and 30 720p30 decoding with ResNet. For your usecase, not sure if your requirement can be achieved. You may need to modify the config file to give it a try.

Not quite sure about what config file you mean.
I’m talking about this https://youtu.be/vuFo7TBisbI video, which demonstrates inferencing throughput of 1850MP/s, which corresponds to 30x 1080p 30fps. And “just over 1ms” processing time is stated.
While running TRT SSD+MobileNet sample takes more than 10ms for a single 300x300 image.
Am I missing smth?

Hi,
The video is demonstrated in running the config in deepstream sdk:

deepstream_sdk_on_jetson\samples\configs\deepstream-app\source30_720p_dec_infer-resnet_tiled_display_int8.txt

Do you run SSD+MobileNet on deepstream sdk? Or you run it on tegra_multimedia_api?

I run it through TF or TFTRT.

Okay so I’m close, I ran the deepstream-app -c , then got the following:

buf_convert: Wrong src surface count in ConvertBuffer

Warning. Could not open model engine file /home/keith/Documents/DeepStreamSDK-Jetson-3.0_EA_beta5.0/deepstream_sdk_on_jetson/samples/configs/deepstream-app/…/…/models/Primary_Detector/resnet10.caffemodel_b30_int8.engine

The DeepStream window pops-up (black) then closes within a few seconds.

Hi keithdm,

Please try to remove gstreamer cache and run again:

$ rm ${HOME}/.cache/gstreamer-1.0/registry.aarch64.bin

Hi carolyuu
it’s still not work for clean gstreamer-1.0, DeepStream window pops-up[black] then closes within a few seconds.

Hi jacky1127s,

Are you install JetPack-4.1.1 all packages? (CUDA, cuDNN, TensorRT, OpenCV, VisionWorks)
List steps for you reference:

Install JetPack-4.1.1 on Xavier
Install prerequisites packages:
$ sudo apt-get install libssl1.0.0 libgstreamer1.0-0 gstreamer1.0-tools gstreamer1.0-plugins-good gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly gstreamer1.0-libav libgstrtspserver-1.0-0 libjansson4
scp "deepstream_sdk_on_jetson_partner.tbz2" to your device
cd deepstream_sdk_on_jetson folder
sudo tar -xvf binaries.tbz2 -C /
sudo ldconfig
Run the samples:
$ deepstream-app -c samples/configs/deepstream-app/source4_720_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt

Please reference README on deepstream_sdk_on_jetson folder for detail steps.

What is the ETA of DeepStream for L4T 32.1?

So I followed this but I’m using Jet Pack 4.2 on Xavier and the latest deepstream 3.0.

Hi,

It is uncertain and under evaluation currently.

The release is specifically for Jetpack 4.1.1