Very serious bug with the Robot Description Editor (2023.1.1)

Recently I was working on a custom robotic arm, And use lula RRT planning,which is unfortunate, but I ran into many, many problems that I couldn’t solve. I saw a lot of people on the forum who had some experiences similar to mine, and I tried it, but I couldn’t solve it.

When I customize a robotic arm, I export it as URDF, then import URDF and expand IsaacExamples → Workflows → ArticulationInspector. As a test, it works. When I was creating Yaml through Robot Description Editor, it prompted an error of “list index out of range”. I saw many people on the forum experiencing this, and I think it is very serious because in development, we use isaac sim to test many different robots, not just the defined types of robotic arms.

I would like to seek help. Is there a way to create a custom robotic arm. yaml or is there any improvement in future plans?

@fsb0147 This is a known issue that will be fixed in the upcoming release of Isaac Sim. As of the last release, the URDF importer places the articulation root of the asset as the base link rather than the asset path. I.e. for the UR10, the articulation root path would be /ur10/base_link instead of /ur10. The Robot Description Editor assumes that the asset path is the base path of the asset.

A workaround for now would be to change the articulation root on your imported asset. You don’t have to save over the change or keep the new asset, this is just to be able to use the robot description editor to generate spheres in a config file. With the timeline stopped:

  1. Remove the Articulation Root by clicking on the red x under Property -> Physics -> Articulation Root wherever the articulation root is.

  2. Select the asset path and click Add->Physics->Articulation Root


1 Like

@arudich Thank you very much for your help, I have successfully made yaml.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.