VI performance issue with 6 AR0233 cameras on roscube-x?

Can’t find any error from the dts,
Is it possible to try 6 sensors without virtual due to your design are 2 lanes you can reference to e3333 for 6 camera without VC.

Hi Shane,
I don’t think this is possible, as explained in my posts here. While the second CSI port on each MAX9296 deserialiser is connected, NVIDIA’s driver does not appear to support their use.

I have run four cameras, one on each interface, and this works fine, as does 5 cameras in any arrangement.

So you are using Leopard’s sensor board?

Yes

@SimonZhu
Could you help to check if any idea for this issue.

Hi Chris5,

We have Xavier AR0233-GMSL2 driver for Nvidia Jetson AGX Xavier Devkit, and this driver supports 2048x1280 Linear mode and 1920x1080 HDR mode. Each MAX9296 can support two cameras (8 cameras supported in total). The source code can be downloaded from the dropbox link in 1st page of below driver guide. Hope it can be a reference for driver development on Roscube-X.

Hi Simon,
I’m guessing that you have come up against the same issue, as your HDR mode does not use the full resolution of the sensor.

@ShaneCCC

I don’t think this is a problem with Leopard’s hardware or the driver because:

  • I can get full size raw images using V4L2, from 6 cameras at full frame rate, while I can only get this from 5 cameras when using Argus via gstreamer
  • I can get full size images through Argus via gstreamer from two cameras on the the deserialiser, therefore the deserialisers can handle this rate, as can the CSI port. I have tried all deserialisers in this way
  • The camera that does not produce images changes each time I launch the streams.

It seems very likely that this problem is related to the Jetson module itself, downstream of the CSI interface, because this works when using V4L2

@SimonZhu @chris5
Any condition working for gstreamer pipeline?

@chris5 Have you tried the linear mode or HDR mode with 1080P resolution on the same hardware? Do you see the same issue?

Yes, linear mode works.
Gstreamer works in HDR with full resolution for up to 5 cameras.
The leopard 1080P HDR mode isn’t working for us.

We also sometimes get the attached errors in the kernel log. The only way to recover when this happens is a hard reboot, disconnecting and reconnecting power to the system

kernel_output (142.8 KB)

Looks like there have i2c failed not sure if it relative the issue or not.