vkCreateDevice with Vulkan 1.1

I just updated my game engine to Vulkan 1.1 and since then the function “vkCreateDevice” fails and throws an “access violation writing location 0x00000000” at 0x693379B3 (nvoglv32.dll).
I checked all attributes of the “VkDeviceCreateInfo” and they seem fine. Even though I have enabled the “standard validation layers” on my VkInstance I don’t get any message, which is weird.
First, I thought my driver was outdated, so I downloaded the beta driver “389.10-NProfile”, which as far as I know should support Vulkan 1.1, but it still doesn’t work.

What’s the issue?

btw: the exception is thrown at 0x693379B3 (nvoglv32.dll)

hi lwirth2000

  1. Can you attach the minimal simple test project ?
  2. Did you try to execute some other examples ?

Same here, on GTX960 391.35, Vulkan SDK

I only get this error when enabling the VK_LAYER_LUNARG_assistant_layer

So I have fixed the problem for quite a while now. I just used the new release of the Vulkan-API ( and it just worked fine for me. Seems like there was a bug in the version I hope this also works for you.

Thanks for the help!

Do you have the VK_LAYER_LUNARG_assistant_layer enabled?