Wanting to use a microSSD on a eMMC production board but no instructions

I purchased a Jetson Nano production board with 16Gb eMMC since it was the only B01 (or I think since it has 2 camera slots). I have tried to follow along with the course “Getting started with AI on Jetson Nano”, but it’s just been a 3 day struggle to get past the “Setting up the Jetson Nano”.

The instructions said that you can do this through windows. Well, not with the eMMC (which was basically the only B01 versions currently available only to see that the Nano is now basically obsolete after the Orin came out, but is unavailable for purchase currently).

The eMMC came flashed, but had issue for remote connection that I had to fix and took forever since I am new to Ubuntu. Oh, did I mention that seems to be a common problem, but is still shipped with Linux?

I have tried to pull the latest jetpack only to have space issues. My eMMC is 16Gb and it’s not enough for the basic tutorial.

I have tried to pull 6.1 only to have space issues.

This is after I have uninstalled LibreOffice and Thunderbolt to clear space.

So then I try to make it boot from microSD, but that seems impossible because there are no clear solutions (even the author of the references states that he is “sorry that there isn’t a clear solution”.

Would it be that hard to actually make some clear documentation for those with production bards so we are able to use a mircoSD for everything but the Linux boot?

NVidia should know that people would end up with production boards and not be able to even follow the basic tutorials. Why isn’t there any clear support?


Regarding the microSD issue, I think there are some misunderstanding here.

There are two kinds of jetson nano modules. One is sdcard module with sdcard slot on the module.
Another one is emmc module which does not have sdcard slot but only emmc.

The website which tells you that you can flash a “sdcard image” on Windows machine is basically for sdcard module. Not for emmc module.

Then the next problem is, then why you have a sdcard slot there. That is the uncertain part. I guess it is probably on the carrier board itself. And how that carrier board is coming from is not what I can answer.

If that carrier board is made by you, then we can guide you how to modify kernel and device tree to enable that sdcard slot.

However, if that carrier board is just bought by you and you have no other info about it. For example, schematic or driver code, then we are not able to guide you what to do. You need to find the board vendor for help. Generally they already got help from us and enable that sdcard slot with their BSP.
You need to contact them for that BSP.

BTW, there is also a guide for minimizing disk usage here:

Thank you for the direction. I tried to use those commands only to have broken dependencies and then needing to re-install them with the ‘fix-broken’ command.

So, unfortunately it didn’t work.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.