When decodeing rtsp stream with nvv4l2decoder block

Hello, I am in the latest version Jetpack 4.5 on Jeston NX, when i using nvv4l2decoder to decode some rtsp stream, the pipeline was blocked, the pipeline is:

gst-launch-1.0 rtspsrc location=rtsp:// ! rtph264depay ! nvv4l2decoder ! fakesink dump=true
nvbuf_utils: Could not get EGL display connection
Setting pipeline to PAUSED …
Pipeline is live and does not need PREROLL …
Progress: (open) Opening Stream
Progress: (connect) Connecting to rtsp://
Progress: (open) Retrieving server options
Progress: (open) Retrieving media info
Progress: (request) SETUP stream 0
Progress: (open) Opened Stream
Setting pipeline to PLAYING …
New clock: GstSystemClock
Progress: (request) Sending PLAY request
Progress: (request) Sending PLAY request
Progress: (request) Sent PLAY request
NvMMLiteOpen : Block : BlockType = 261
NVMEDIA: Reading vendor.tegra.display-size : status: 6
NvMMLiteBlockCreate : Block : BlockType = 261

The pipeline is blcoking, and NVDEC is not working.

I also tried to add h264parse after nvv4l2decoder plugin.I am sure this rtsp server is working, because removing nvv4l2decoder the pipeline worked,

When i using another rtsp stream or the media file to right, the pipeline is right.

Looks like it is running. The sink is fakesink, so nothing is shown.

Please try uridecodebin:

gst-launch-1.0 uridecodebin uri='rtsp:// ' ! nvoverlaysink

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.