When power up, orin nx needs about 45s to boot up. whether the boot time can be optimized or not?

Dear Sir/Madam:

We use a custom carrier board with orin nx and found that from power up to boot up needs about 45s:
bootloader(exclude kernel): 28s
kernel: 17s

in this page talk about how to improve the kernel boot time.

bootloader ??
I want to know whether there is a way to improve the bootloader time or not?


Hi lishu2002,

What’s the Jetpack version in use?

You could refer to the following topic also discussing about boot time optimization.
Orin nano Developer kit takes long time to boot - Jetson & Embedded Systems / Jetson Orin Nano - NVIDIA Developer Forums

Thanks for the reply.

The version we use is R35.3.1

I will check the other topic you offered。

Dear sir:

Question 1:
I had check the topic you offered and know can decrease about 9 second time.
But I found that TX2 needs about 10s before start kernel, is less about 10s than orin nx.
whether orin nx’s bootloader boot time can be decrease more or not?

Question 2:
I had install the packages needed from the wiki: NVIDIA/edk2-nvidia/wiki/Build-without-docker
1) when I run this command: edkrepo clone nvidia-uefi NVIDIA-Platforms r35.3.1-updates
happen a error, but there is nothing flows the following errors

2) error message is :
Cloning global manifest repository to: /home/qskj/.edkrepo/edk2-edkrepo-manifest-main from: GitHub - tianocore/edk2-edkrepo-manifest: Platforms manifests used by the edkrepo utility
The git command: git clone --branch=main --progress --single-branch
-v GitHub - tianocore/edk2-edkrepo-manifest: Platforms manifests used by the edkrepo utility /home/qskj/.edkrepo/edk2-edkrepo-manifest-main failed to complete successfully with the following errors.

3) so i use http to get a zip file, unzip and switch to r35.3.1-updates branch

4) after that when use cmd[edk2-nvidia/Platform/NVIDIA/Jetson/build.sh] to build, can not build and happen error is :
error: must be launched from the workspace root.

how can i build the UEFI?

TX2 come with R32.X, which uses Cboot as bootloader.
However, Orin NX come with R35.X, which use UEFI as bootloader.
They have significant difference in architecture for bootloader.

Do you refer the every steps in wiki and setup the build environment w/o any errors?
Are you using standalone Ubuntu 18.04 or 20.04 as host PC?

thanks for the reply.

  1. I use a 20.04 virtual machine

  2. What i did include below 4 steps, in which step 3 failed:
    step 1: Install edkrepo[success]
    I run cmd in the pic

stpe2: config edkrepo with cmd in pic[success]

step3: clone git [failed]

step4: Install EDK2 developer environment

  1. install package [success]

  2. install mono [success]

I would suggest using standalone Ubuntu 18.04 or 20.04 to develop the Jetson device because you may have connection issue during flash through VM.

It seems the permission issue from your VM host.

Could you help to try using sudo for step3?


  1. Even use root user Step3 still error

  2. also use root user to run build.sh, still failed

Could you share the result of the following command?

ls -al ~/.edkrepo

Please make sure your network access working and do not enter su mode for these commands.

Is there any result when you run the following command?

$ git ls-remote https://github.com/tianocore/edk2-edkrepo-manifest.git
  1. result of “ls -al ~/.edkrepo”

  2. result of “git ls-remote…”

Yes, this seems the issue about you could not reach the git server.
Could you try any VPN to switch to the other server and try again?

I can use github mirror:
https://hub.yzuu.cf/NVIDIA/edk2-nvidia to visit the website.

but how to modify edkrepo config ?

It seems I could not access your mirror git.

You could try to replace the following line in edkrepo/config/edkrepo.cfg with your mirror git.

URL = https://github.com/tianocore/edk2-edkrepo-manifest.git

ok, I will try,

from the website can not find manifest.xml

so use the clone cmd will fail when use git checkout.

I think the main point is how to compile the code, repo clone just how to download code.

You could just run the command like the following to build the uefi binary.

$ . edk2-nvidia/Platform/NVIDIA/Jetson/build.sh

I had tried but failed. It seems need some workspace for the code.

how did you extract your .zip downloaded from github?

Sorry for the wrong message offered before.

I use git clone cmd got the code, URL & cmd is blow.
I think you can reproduce it just replace hub.yzuu.cf wiht github.com

Actually, I could not reproduce your issue locally…
We could clone from official github source and build the uefi binary.

Please check the permission of files and the directories of your source.
It seems the permission issue on your host.

P.S. I found you just download the git repository of edk2-nvidia…
There should be other repository, too.

Let me share my ls result:

[~/nvidia-uefi]$ ls
Build  edk2          edk2-nvidia          edk2-nvidia-server-gpu-sdk  images  reports
Conf   edk2-non-osi  edk2-nvidia-non-osi  edk2-platforms              repo    venv