While testing cuda 11.7 installation:tracedesigntime, intellisense

I installed VS 2022 then cuda 11.7. All steps showed everything is good.
When testing success of cuda installation, I run nobody_vs2022.sln , It was not successful: I got this :

I updated the environment variable, saw the log and saw things getting complicated when they had to run somoothly as indicated by the installation guide. Also, I did not find clear solution for my specific problems on other forums.
Any help please ?

I haven’t seen this type of issue before. Are you able to successfully build non-CUDA Visual Studio Solutions?

Thanks for your prompt reply.

I run this tutorial in order to check, VS2022 is running successfully:

Introduction to projects and solutions - Visual Studio (Windows) | Microsoft Learn

It was successful, so normally, the answer to your question is : yess I’m able to build non-cuda VS solutions.

unfortunately the error when building cuda sample is still there:
"error : Designtime build failed for project ‘C:.…\cuda-samples\Samples\5_Domain_Specific\nbody\nbody_vs2022.vcxproj’ configuration ‘Debug|x64’. IntelliSense might be unavailable.
Set environment variable TRACEDESIGNTIME = true and restart Visual Studio to investigate.

Thanks for the update. We haven’t seen this in house or been able to reproduce it. I did see online that several users encountering similar messages were able to fix it by using the REPAIR option in the Visual Studio Installer. Would you be able to re-run the installer and see if the Repair option makes a difference?

1 Like

Many thanks for your feedback.

I made the repair of VS2002, then tried to run nbody_VS2022.sln and got a new challenge:


I further got this when building the sln :

"1>------ Build started: Project: nbody_vs2022, Configuration: Debug|x64 ------
1>C:.…Source\Repos\nvidia\cuda-samples\Samples\5_Domain_Specific\nbody\nbody_vs2022.vcxproj(37,5): error MSB4019: The imported project “C:\Program Files\Microsoft Visual Studio\2022\Community\MSBuild\Microsoft\VC\v170\BuildCustomizations*CUDA 12.1.props*” was not found.

Confirm that the expression in the Import declaration “C:\Program Files\Microsoft Visual Studio\2022\Community\MSBuild\Microsoft\VC\v170\BuildCustomizations\CUDA 12.1.props” is correct, and that the file exists on disk.
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========
Build failed."

But what I have already installed is cuda 11.7 not 12.1; so I changed CUDA version in the nbody_vs2022.vcrxproj

What I got when building the sln: Another challenge

Is there any additional information about what the error was besides the fact that it exited with code 1? Any thing else in the output of the build? It’s hard to say what’s happening just from that screenshot.