Windows not detecting 3rd Quadro M5000 but shows in BIOS


I’m not sure if this is the right area in the forum for this but if not just let me know

I have a client at my job I was trying to help out before they purchase a very expensive replacement. The PC runs a ship with 9x1 video wall. The old Asrock X99 WS-E board was running three quadro m5000 with a PNY P2060 sync card. The wall was setup via Nvidia Mosaic. The mobo had failling pcie slots along with heat damage to 2/3 of the old cards.

We bought a refurb Asus X99 WS-E board, kept the Intel Xeon E5 CPU and the 32gb of ram. I also purchased a 1000w PSU since the original modular PSU had no extra cables supplied when it was built.

Long story kind of short, I have installed a fresh Windows 10 system, and new drivers. It seems like the cards will start detecting but 1/3 of them will have an exclamation error in Device Manager or it will be completely gone from Device Manager. If I switch PCIe slots around i can still only get two cards to work. Even then, i’ve been getting VIDEO_TDR_Failure bluescreens.

I’ve also tried older Quadro drivers from 2019 that seemed to have some extra content compared to the new drivers (Ansel). Neither versions work. I’ve also updated the BIOS to its’ latest version.

The mobo sees each of the cards in the bios and has them running at gen3 x16.

Am I missing something here? Shouldn’t these three cards all detect and then sync with the sync card? Why is the third one giving me such problems? I even tried one of the other cards that we had pulled just in case the refurb wone was failing and I still had the same result. Anything else I could try?