Mosaic problems running 3xRTX5000 and Quatro Sync II on Ubuntu - worked with older P4000 cards

Hi There, We have a Setup with 12x 75" Vertical Screens as a 360 Panorama Wall.
Till last year we were running 3x P4000 Cards with a Quadro Sync II under Ubuntu/Lubuntu 20.04
After some initial troubles configuring Mosaic, it was running perfectly fine.

To gain more graphics power we upgraded to 3x GTX 5000 Cards with a Quadro Sync II last month but now i am unable to get the thing up and running again. Cards are detected, Screens aswell, but as soon as i try to configure mosaic (via nvidia settings or manually via xorg.conf the xserver gets stuck.

If i remember right, ist worked just after replacing the old cards with the new GTX 5000 and booting up the machine.
Then i upgraded the System (and nvidia drivers) and now im not able to get a running config anymore.

I guess something has changed in the recent NVidia drivers, it it possible that the adressing/naming of the cards or outputs have changed?

Does anyone have a working config for mosaic with a RTX5000 and a recent Ubuntu/NVidia Driver version that i could use?

here is my old working config lines:

Option         "SLI" "Mosaic"
Option  "MetaModes" "GPU-1.DFP-6: 1920x1080_60 +0+0  { Rotation=left }, GPU-1.DFP-4: 1920x1080_60 +1120+0  { Rotation=left }, GPU-1.DFP-0: 1920x1080_60 +2240+0  { Rotation=left }, GPU-1.DFP-2: 1920x1080_60 +3360+0  { Rotation=left }, GPU-0.DFP-6: 1920x1080_60 +4480+0  { Rotation=left }, GPU-0.DFP-4: 1920x1080_60 +5600+0  { Rotation=left }, GPU-0.DFP-0: 1920x1080_60 +6720+0  { Rotation=left }, GPU-0.DFP-2: 1920x1080_60 +7840+0  { Rotation=left }, GPU-2.DFP-6: 1920x1080_60 +8960+0  { Rotation=left }, GPU-2.DFP-4: 1920x1080_60 +10080+0  { Rotation=left }, GPU-2.DFP-0: 1920x1080_60 +11200+0  { Rotation=left }, GPU-2.DFP-2: 1920x1080_60 +12320+0  { Rotation=left }"

Unfortunately i can’t give more info right now due to homeoffice, will be back on the machine next week to try again.

Hi,
Sorry to hear that.
Have you tried to put back the Quadro P4000 to check if this a corruption in the system or hardware related?
I would also recommend reinstalling the drivers and regenerate the xorg.conf using nvidia-xconfig. Type ‘man nvidia-xconfig’ to get more information.
Then use the GUI (nvidia-settings) to create the mosaic.

Thanks
AP