Xavier AGX dev kit shutdown problem

I am working with the Xavier dev kit and have Jetson 4.3 release installed. I have 2 FLIR camera installed on the Xavier unit.

I have an issue where the Xavier shutdowns right away. It was easy to create the issue.

Here are my test scenarios:

  1. When I run my software and with the jetson_clocks at the highest settings and nvpmodel = 0, the Xavier shutdown.
  2. When I run my software with the jetson_clocks is INACTIVE and nvpmodel = 2, the Xavier does NOT shutdown

For #1, I was able to run the “jtop” to capture the current activity BEFORE it shutdown. See below the screen shot. Is there a reason why the Xavier would shutdown at the maximum power? What should I do to debug this? Any logs I can look at?

I have 3 other Xavier that are in the same #1 setup and have no problem with them.

Any thoughts?

thanks ahead of time

If power consumption causes insufficient power, then it would just shut down. Are all units using the power unit supplied with the AGX? If not, then I would suspect differences in power delivery. If they are all using the provided power supply, then you might try swapping supplies and see if the issue follows the power supply or the Jetson. Similar with the cameras…USB3 cameras can consume a lot of power, and you might try swapping cameras to see if it follows cameras (in which case I’d suspect one camera is using more power than the other).

thank you. I will try that out

Thank you. Your suggestion helped!