Xavier Nx won't restart

Seems to be bug in jetpack 5.01. I have a non-bootable 3.5 inch 2tb hard disk attched by usb to jetson xavier nx development board which I used for backing up my files. If I re-start my machine with the disk powered up the xaver NX will just hangs. When I disconnect the usb cable the system re-starts OK.
I have just tried to restart with nvme disk (powered by usb) attched with usb cable this works fine,

Hi,

This should be posted over in the Jetson Xavier NX forum, I will move it over for you.

1 Like

Thanks

Any uart log to share here?

Not that I’m aware of as there is no response from the xavier nx until I disconnect the USB cable fron the hard drive.I think I can replicate the problem if you can give me a clue about uart log’s
Cheers

You can learn to use jetpack4.x to dump uart log first.

What do you want to say here? These logs totally provide no help.

Sorry but neither does a machine that wont turn on until you disconnect the usb device that is causing the problem…The xavier nx works fine as far as I’m concerned as long as you turn the disk on after it has booted. The problem I suspect is the disk as it goes to sleep when not being accessed, hence when you reboot the xavier wakes the disk up and probably tries to boot from it as apposed to the installed nvme.

What else do I have to buy . I have just had to buy a laptop,get it to duel boot,spend 2 days getting the gtx 3600 graphic card to work on the Ubuntu Boot,SDK manger to upgrade the nvme to jetpack 5.01 . I only started this thinking I was helping someone who may have the same problem!

Having said all that I would like to thank you for help.
P.S. The nvidia visulizations on the ubuntu machine not working. MY next project.
Cheer

I appreciate your endeavor here. But only telling the symptom may not really help.

For example, we may never know if the issue you hit is only on some specific usb disk or not. Maybe it is happened to one brand but it won’t happen on another brand. I’ve seen lots of cases happened like that before.

It is only the uart log that can tell what is going on. To be more specific, if that is kernel panic, then only uart can print the driver stack dump in time. If you just reboot the device, that log would be gone.

Just ordered magic cable. Won’t be here till Friday

Here is some of the serial log
Booted ok no HD connected
Connected HD then rebooted
Goes into LOOP
Turned off HD, then continues rebooting ok
SerialBoot (137.1 KB)

Did you get a chance to look at the log?
Cheers

Hi,

Is it possible to get the full log around this? From my text reader I can see some error “seems” from gpu driver.
But as you can see the log is not human-readable.

[ 165.898506] scsi 0:0:0:0: Direct-Access WDC WD20 EARX-32PASB0 51.0 P6
[ 165.901969] sd 0:0:0:0: [sda] 3907029168 512-byte logical blocks: (2.00 TB/1)
[ 165.902205] sd 0:0:0:0: [sda] 4096-byte physical blocks
[ 165.905790] sd 0:0:0:0: [sda] Write Protect is off
[ 165.906457] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doeA
[ 165.907498] sd 0:0:0:0: [sda] Optimal transfer size 33553920 bytes not a mul)
[ 165.957287] sd 0:0:0:0: [sda] Attached SCSI disk
[ 268.167931] sd 0:0:0:0: [sda] Synchronizing SCSI cache
[ 271.679308] nvgpu: 17000000.gv11b nvg� ��)WE22�+B]pired_m2.4cpu:112 [ER
�.���jQ’j9645] nP��+�2^��!�J�b�(����X �� �r��RJ>@rd� 4
�+��]J>@C+Ep eWk ’ ��%�%�V+�(9V��� � �2�C5
�k�(��V� !2խ)���k��� 5
[����WJ>@tr �
5
r
SPE VERSION #: R01.00.18 Created: Jan 29 2021 @ 14:18:27�-�j�TW�.2h6�JJ�2� .
HW Function test ��!���-�)'j�1�,WH[��r�R�RJs�
2��. 5
Start Scheduler. j
in late init ���rNLW�T��) ���Zr�E ��5J(UH[��)�N � S �
����V��k]< W��p0`0����J�1����PC� *
[0000.922] I> Welcome to MB2(TBoot-BPMP) (version: default.t194-mobile-f46b96)
[0000.923] I> DMA Heap @ [0x526fa000 - 0x52ffa000]

Also, I feel you didn’t dump the full length of each like in your log…

For example, that “Linux version 5.10.65-tegra” line should give out a date. But it only gives “(2”… This case happened to every line you shared…

Thanks for your patients

This is normal boot serial output. There are still some non ascii charaters at the begining of the boot.
The file does not seem to be truncated at 80 characters.
Is this what you expect from a normal boot ?
output1.txt (64.3 KB)
Cheers Paul

Hi,

Just want to clarify again. I am not asking you to dump me another “normal log”. I don’t need such log.
What I want to check is the log when error happened.

Here is the log stuck in a loop
output.txt (18.6 KB)
I let it loop a couple of times.

Cheers

Thanks. This provides more info this time.

May I know

  1. What kind of disk is in use here? Brand name?

  2. What is the scenario to hit error with this disk? For example, plug in and it will 100% hit error, or it is intermittent issue? or any special steps to reproduce issue?

  3. Was this disk able to work fine on some old jetpack release like jp4.6.2?

  4. Have you tried other brand of the usb disk?

  5. Is this a pure usb disk or there are some adapters involved? or through another usb hub, something like that.

Western Digital 2tb (Sata) 5 1/2in
In UGreen usb3 enclosure which is powered.
Connected to usb3 hub

The disk goes to sleep when not bing accessed this is where the problem starts if you reboot. You can hear the system trying to access the disk hence looping.
The disk was not a problem on my previous jetpack 4.6
I have usb nvme3 disk which works fine connected to the same hub
I have just tried old freecom hard disk in it own enclosure which when you reboot turns itself off then turns back on and the system reboots fine.
In conclusion its the ugreen enclosure which puts the disk to sleep when not being accessed.
For me this is not a problem as I only use these disks for backup.
Hope this helps.
Ps I am quite willing to test any other senario

HI,

Is it possible to direct test this disk on the usb port instead of going through the usb hub? Just want to simplify the path