XRDP login profile different from boot with monitor

I am able to install Xrdp on my Jetson Nano and have no problem connecting from Remote Desktop. However when I connect through Remote Desktop it’s a different profile (Just the Ubuntu profile) from booting directly with a monitor connected. I am wondering if I can connect from Remote Desktop and have the same profile just like booting with a monitor. If not how do I change the power mode from remote session?

I can’t answer the Xrdp part, but you can change power model on command line via “nvpmodel”. Max power level is “sudo nvpmodel -m 0”. I don’t know what each model has for specifics when not using max power mode, but you can look at this file for (A) a default, and (B) other mode information:


(note that “t210” is a reference to the SoC used on the Nano…other variations of this are different Jetsons)

Also note that the command line of “nvpmodel” has a lot of useful options for setting or displaying information. See “nvpmodel --help”.

Although I can’t help with Xrdp, understand that how you start X changes what configuration files it loads. Starting X locally likely uses different config files versus starting X remotely. I don’t know how to tell it to use the normal “local login” configs, but if that can be done, then it should start the same as a “regular” (local) login.

Thanks a lot, I think that’s a good direction.

Thanks for pointing to a good direction. After looking for how to change XRDP desktop environment online below works for my Jetson Nano 2gb that uses LXDE as local desktop environment.

sudo vim /etc/xrdp/startwm.sh

Then comment out lines below

#test -x /etc/X11/Xsession && exec /etc/X11/Xsession
#exec /bin/sh /etc/X11/Xsession

At last add startlxde to let remote session to use local desktop environment.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.