2 out of 3 monitors turns off for a few seconds approximately 10 minutes after starting up

Every day when I boot my computer up I have been running into an issue where my left and middle monitor will turn off for a couple of seconds and then come back on. Typically my middle monitor goes off first, recovers, and my left monitor does the same thing a few seconds later. It is very common that the left monitor does not recover and stays “asleep”. This issue has been happening consistently approximately 10 minutes after startup.

To fix the sleeping monitor I need to open up nvidia-settings and change the refresh rate for my monitor, apply settings, and change it back. This works 90% of the time. Other times I need to repeat this process for it to work.

OS: Kubuntu 20.04
Kernel: 5.13.0-30-generic
DE: KDE Plasma 5.18.8
NVIDIA driver: 510.47.03
3 identical monitors 1080p@240hz all running on display port from an RTX 2070 Super.

Where should I start to debug this issue?

You could try adding Option "ConnectedMonitor" as detailed in:


In your xorg.conf file,

Section "Screen"
     Option "ConnectedMonitor" "DFP-0, DFP-3, DFP-5"

based on what you posted of /var/log/Xorg.0.log in your other thread.

From what I understand, this will force those output ports on, whether they’re connected to a monitor or not. This override means that even if you disconnect the monitor, the card will still think there’s a need to output to that port, if that matters to you. I think this will ensure that the monitors stay connected to the graphics card.

Screen blanker and monitors go to sleep per normal, at least on my system.

(edited: code blocks for clarity)

Just gave it a shot, no luck unfortunately. After adding that to xorg.conf it got stuck on the BIOS splash screen that appears during UEFI boot and it never made it to the login manger. I had to live boot and revert it.

I think this is the corresponding log for when that happened It looks like I might have entered it wrong, I will try again:

[    12.662] (--) Log file renamed from "/var/log/Xorg.pid-3543.log" to "/var/log/Xorg.0.log"
[    12.663] 
X.Org X Server 1.20.13
X Protocol Version 11, Revision 0
[    12.663] Build Operating System: linux Ubuntu
[    12.663] Current Operating System: Linux cgpc 5.13.0-30-generic #33~20.04.1-Ubuntu SMP Mon Feb 7 14:25:10 UTC 2022 x86_64
[    12.663] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.13.0-30-generic root=UUID=45255dc8-65e2-4ea6-b919-34c471cd8d3b ro quiet splash vt.handoff=7
[    12.663] Build Date: 14 December 2021  02:14:13PM
[    12.663] xorg-server 2:1.20.13-1ubuntu1~20.04.2 (For technical support please see http://www.ubuntu.com/support) 
[    12.663] Current version of pixman: 0.38.4
[    12.663] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    12.663] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    12.663] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Apr 20 01:56:57 2022
[    12.663] (==) Using config file: "/etc/X11/xorg.conf"
[    12.663] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    12.663] Parse error on line 62 of section Screen in file /etc/X11/xorg.conf
	The Option keyword requires 1 or 2 quoted strings to follow it.
[    12.663] Parse error on line 62 of section Screen in file /etc/X11/xorg.conf
	"“DFP-0," is not a valid keyword in this section.
[    12.663] (EE) Problem parsing the config file
[    12.663] (EE) Error parsing the config file
[    12.663] (EE) 
Fatal server error:
[    12.663] (EE) no screens found(EE) 
[    12.663] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    12.663] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    12.663] (EE) 
[    12.663] (EE) Server terminated with error (1). Closing log file.

Yea it definitely looks like it was an issue with the styled double quotes from the thread… Still don’t understand why those need to exist, especially on a technical forum such as this one. Trying again.

I was able to boot correctly with the Option "ConnectedMonitor" "DFP-0, DFP-3, DFP-5". Now I just need to wait and see if the problem happens again.

I’ve actually noticed that the issue only happens once a day, primarily after the first time I boot the computer, and subsequent boots don’t necessarily do it again, so time will tell. I really hope this will fix it, but its slightly annoying that this would be required for things to work properly.

Thank you for the help!

Ugh… sorry you had to live boot for recovery!

I didn’t notice that this forum automatically translates double quotes to open/close quotes. I’ll be sure to enclose in a code block next time.

Hope it works out for you!


I will try to set some sort of reminder to post an update in a few days.

No luck! I thought I caught it happening again yesterday, but I wasn’t sure because I was partially afk. Both monitors remained on yesterday. Today it happened again, but the left monitor stayed off. So the problem still remains.

In hindsight, I guess it makes sense that that this configuration might not work as the monitors has always been visible in nvidia-settings when it happens, so it’s not like xorg thinks the monitor is disconnected. Here is a screenshot of my settings while my left monitor is currently off:

After this I performed my usual fix of changing the refresh rate and changing it back. So at least I have the rest of the day not to worry about it…

Aw, bummer… maybe KScreen 2 might be affecting things?

On openSUSE, it’s Settings->System Settings->Background Services/Startup Services/KScreen 2.

I see that it is running. Are you suggesting that I disable it? Is there a way to disable it from a config file? I would prefer to do it that way the case that it breaks something so I can fix it from a live boot.

Yes. It’s another thing that might affect the monitors after the system wakes up. In my particular situation, I’m going through a KVM, which caused monitor wake-up to be problematic, as maybe the signal isn’t picked up properly. I’m wondering whether the 240 Hz refresh you’re using is also something to do with signal.

KScreen 2 allows the system to automatically reconfigure the desktop as monitors are added and removed, e.g. add a monitor and KScreen 2 configures it as an extension of the desktop. If your system is fixed, i.e. you’re not adding monitors on the fly, like with a laptop, then there’s no need for KScreen 2.

It’s something to try.

I disabled it right when I started my computer, but no luck. I still had the issue where my monitors did the strange turn off cycle. However my left monitor did not get stuck in the off position this time, but this has been intermittent anyway, so I’m not sure anything has changed.

The only random thing I can think to try next is to reduce the refresh to 60 Hz, see if that works for stability, and if it does, you can report that 240 Hz (the desired refresh) is causing problems with monitor sleep and wake-up.

Eh, maybe I will try 120 first, 60 is rough. Maybe I could even bump up to 280 first to try that. I will try different refresh rates at some point, but I won’t be able to for at least a week and a half. Where would I even report the problem even I find that is the case?

Switching to a lower refresh rate isn’t meant to be a permanent solution, just a way to debug. The resolution of your monitors is pretty standard, 1080p, but the refresh is higher than the normal 60 Hz.

As for reporting, I would guess here and perhaps tag someone from NVidia. They usually need logs and something reproducible.

Finally getting a chance to circle back to this. I switched to 120hz for a while, and everything seemed to work fine. So I would assume this has to do with the 240hz. I just updated to 510.73.05 to see if that fixes the issue in the mean time.

If the problem is not fixed by the update, how do I tag someone from Nvidia? Is that what you are supposed to do on these forums?