20fps when using nvsipl_camera with custom plugin

Please provide the following info (check/uncheck the boxes after clicking “+ Create Topic”):
Software Version
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version
other

Target Operating System
Linux
QNX
other

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)
other

SDK Manager Version
1.5.0.7774
other

Host Machine Version
native Ubuntu 18.04
other

Hi,
When I try to enable the custom plugin when using the entron AR0820 camera I noticed the frame rate drops from 30fps to 20fps. How can I avoid the frame drop?

I also tested with sekonix AR0231, there is no frame drop issue.

./nvsipl_camera -c F008A070BM0A_24BIT_RGGB_CPHY_x2 --link-enable-masks '0x0001 0x0000 0x0000 0x000' -d 0 -w 1 --showfps --plugin 1
MAX96712: Revision 2 detected
MAX96712 Rev 2: Link 0: Tx amplitude 0x28, 0x68, 0xb3, 0x72, 0xd2
MAX96712 Rev 2 manual adaptation on the link 0 (31)
MAX9295: Revision 8 detected!
Sensor AR0820 GRBG Rev 2.1 detected!
Module_id 22 Severity 6 : NvMediaICPCreateEx 76
Module_id 22 Severity 6 : T19x VI version  0x000019
nvsipl_camera: Opened NITO file for module "F008A070BM0A_24BIT_RGGB"
Enter 'ld' to list display-able outputs.
Enter 'e' followed by 'ID' to enable display for specific camera group
Enter 'les' followed by sensor ID to enable LED
Enter 'lds' followed by sensor ID to disable LED
Enter 'q' to quit the application
-
Output
Sensor0_Out1	Frame rate (fps):	19.9989
Sensor0_Out2	Frame rate (fps):	19.9989

Output
Sensor0_Out1	Frame rate (fps):	19.9989
Sensor0_Out2	Frame rate (fps):	19.9989

Nevermind, I found the cause is due to ProcessAE() sets exposure time to max value of 0.039 ms, which causes the slowdown. Limiting total exposure to below 0.033 ms keeps frame rate at 30fps.

1 Like