About xavier nx production module capacity

Hello,

The xavier nx production module capacity is 16GB, which is on the small side.
Should tensorrt, opencv, cuda, etc. be installed in emmc?
Or do I need to store it in an external USB storage, etc.?

Thank you.

Hello @Hodu,

Unfortunately, 16 GB capacity is not enough to install Jetpack SDK components. You should get an external storage for avoiding problems. We have tried to install Jetpack SDK components to Xavier NX module and we couldn’t do it. We have deleted ThunderBird and LibreOffice programs before installing components. Keep in your mind , you can delete the components when you start to install so you should delete before to start the installation process.

Regards.

1 Like

Thanks for the reply
Even if you uninstall ThunderBird and LibreOffice programs, the capacity to install Jetpack SDK will be insufficient, isn’t it?

How to install Jetpack SDK?
How do you use SDKManager?
Use apt install?

Thank you.

You should install “sdkmanager” to your linux host computer not to your jetson module. Sdkmanager provides you to install Jetpack operating system and jetpack components easily. You can get some help from the document in the below.

https://docs.nvidia.com/sdk-manager/download-run-sdkm/index.html

For installing Jetpack, please check this document.

Regards.

https://docs.nvidia.com/jetson/jetpack/install-jetpack/index.html

1 Like

But it’s not suitable for mass production.

is there any other method to install jetpack?

Thank you.

We are working on this issue. Soon, we will publish a blogpost from our website (www.forecr.io). I will confirm you when it is published.

1 Like

We tried it on Jetson Nano (commercial module - 16 GB EMMC).

First, we installed Jetson OS with SDK Manager.

Then we installed jetpack components with this commands:

sudo apt update
apt depends nvidia-jetpack | awk '{print $2}' | xargs -I {} sudo apt install -y {}

https://docs.nvidia.com/jetson/jetpack/install-jetpack/index.html#install-jetpack

We had 1,7 GB free space.

Screenshot from 2021-05-28 10-19-36

Finally, we removed libreoffice* thunderbird* packages, cleared the apt cache and removed unnecessary packages. Then, we got 2,3 GB free space.

sudo apt-get remove libreoffice* thunderbird*
sudo apt-get clean
sudo apt-get autoremove

Screenshot from 2021-05-28 10-23-39

We will try it on Xavier NX too.

Regards

1 Like

Thank you very much

Download l4t from the above url
Can’t I flash with sudo ./flash.sh jetson~.config mmcblk0p1 command?

Thank you.

Of course, you can do it via flash.sh.

1 Like