After flashing apt won't upgrade packages

just flashed with 5.0.2; with few passed failures during sdkcomponents install though

sudo apt upgrade -y
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-l4t-nvpmodel-gui-tools : Depends: nvidia-l4t-core (= 35.1.0-20220810203728) but 35.1.0-20220825113828 is to be installed
                                 Depends: nvidia-l4t-init (= 35.1.0-20220810203728) but 35.1.0-20220825113828 is to be installed
                                 Depends: nvidia-l4t-nvpmodel (= 35.1.0-20220810203728) but 35.1.0-20220825113828 is to be installed

Hi _av,

Are you using the devkit or custom board?
How did you flash the board?

Are you running this upgrade command on the board?

Please try the following command to check if it could help

$ sudo apt --fix-broken install

resolved by reflashing
command above wouldn’t work

I am seeing the same problem repeatedly, even after reflashing with Jetpack 5.0.2.

It seems to be consistently happening after performing: sudo apt install nvidia-jetpack

Subsequent sudo apt upgrade commands have the same error as the OP suggested.

The package manager recommends sudo apt --fix-broken install

This tries to upgrade the following suspect packages:
The following additional packages will be installed: nvidia-l4t-nvpmodel The following packages will be upgraded: nvidia-l4t-nvpmodel

However this fails with the following error
E: Sub-process /usr/bin/dpkg received a segmentation fault.

Any subsequent use of apt appears to be broken, for example: sudo apt install nano has the same error as OP.

Any suggestions for a way forward here? I am using a devkit

Hi chh,

How did you flash the devkit?
Are you using standalone Ubuntu 18.04 as your host PC?
It looks like another issue as here, please file another topic to clarify.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.