After Upgrading Yesterday Can't Create Materials

The error says ‘Omniglass.mdl’ cannot be loaded. Are there syntax errors?

I have also tried OmniPBR and it is the same thing.

I thought it was a project I was working might have errors, so I tried a brand new project and it is the same issue.


can confirm it happens in 2023.2.0 and not scene/project related. below is from the log (of an OmniGlass material).

2023-09-28 17:03:18 [313,933ms] [Info] [rtx.neuraylib.plugin] [EntityResolver] FAILED  ::Z73file_3A::Z16C_3A::users::simpl::appdata::local::ov::pkg::ZB0create_2D2023_2E2_2E0_2Dprod_2E2::kit::mdl::core::Base::OmniGlass  <--->  ::Z73file_3A::Z16C_3A::users::simpl::appdata::local::ov::pkg::ZB0create_2D2023_2E2_2E0_2Dprod_2E2::kit::mdl::core::Base::OmniGlass  (NULL)
2023-09-28 17:03:18 [313,933ms] [Error] [rtx.neuraylib.plugin] [MDLC:COMPILER]   1.0   MDLC   comp error: C120 could not find module '::Z73file_3A::Z16C_3A::users::simpl::appdata::local::ov::pkg::ZB0create_2D2023_2E2_2E0_2Dprod_2E2::kit::mdl::core::Base::OmniGlass' in module path
2023-09-28 17:03:18 [313,933ms] [Warning] [rtx.neuraylib.plugin] Loading MdlModule to DB (rtx_scope0) failed: ::Z73file_3A::Z16C_3A::users::simpl::appdata::local::ov::pkg::ZB0create_2D2023_2E2_2E0_2Dprod_2E2::kit::mdl::core::Base::OmniGlass
2023-09-28 17:03:18 [313,933ms] [Warning] [rtx.neuraylib.plugin] Loading transaction committed (this thread). MdlModule is NOT in the DB (rtx_scope0): ::Z73file_3A::Z16C_3A::users::simpl::appdata::local::ov::pkg::ZB0create_2D2023_2E2_2E0_2Dprod_2E2::kit::mdl::core::Base::OmniGlass
2023-09-28 17:03:18 [313,934ms] [Warning] [omni.kit.material.library.material_library] process_ov_neuraylib: failed to get module from C:/users/simpl/appdata/local/ov/pkg/create-2023.2.0-prod.2/kit/mdl/core/Base/OmniGlass.mdl
2023-09-28 17:03:18 [313,941ms] [Error] [omni.usd] [Watcher] Failed to resolve USD Asset Identifier 'C:/users/simpl/appdata/local/ov/pkg/create-2023.2.0-prod.2/kit/mdl/core/Base/OmniGlass.mdl' from prim '/World/Looks/OmniGlass/Shader'

@DataJuggler i actually just reinstalled Launcher and Composer and the problem went away. I can only suspect that what we downloaded/installed yesterday (when version prod.2 was a thing) and what’s available now in the Launcher are slightly different. so see if that works for you.

It is strange, when I go to the Exchange tab, and click on Composer, it shows me 2022.3,3, but right after I install it shows me an update for 2023.2.0. Did it do the same for you?

I still get the error after uninstalling / reinstalling.

Tonight I may try and reboot and see if that maybe fixes it. Thanks for the suggestion though.

Ok we have figured this issue. It is because we had two different versions of Composer get published yesterday by mistake. We had PROD2 and then the corrected version without the “prod2” addition in the name.

So it seems isolated to people who installed PROD2, then deleted

Unfortunately I already deleted Prod2, and emptied my Recycle Bin last night, so I cannot recover it. I also ran the Cleaner tool, and the issue still happens for me.

Is there a way to download the Prod2 version again?


Ok so in that case, lets do this. Uninstall all copies of Composer so there is nothing at all.
Then just install the new version 2023.2.0.
Try that and let me know. If not I have one more thing to try

It is still happening. What is the other idea? If the patch is coming out soon, I can use 2022.3.3 for now.


OK the other idea is more involved. First question, do you have any other apps installed in the launcher ? If so, would you mind if we deleted them? The idea is to make sure there are no other apps in the launcher, and then we’re going to delete your extensions. Once we have done that you can go ahead and reinstall, and I’m pretty sure this will work,

The extensions are located in C:\users\USER\appdata\local\ov\data. There is a folder called “exts”. Once all your apps are uninstalled (you can keep cache and nucleus) delete the whole exts folder.

Then try reinstalling.

Is this the correct folder? I have 682 folders in this directory.


I will go ahead and delete.


Edit: I just freed up 13.5 gigs. Reminds me of my first computer, a Vic-20, which counting the cassette backup had 13.48 gigs less.

After all that, it is still happening.

Is it possible for you to post the prod2 version that was there yesterday? (even privately?).

Perhaps that will solve it.

I was able to solve this, by deleting my local/appdata/OV folder (115 gig), and uninstalling all the Omniverse Apps and connectors, including the launcher, and reinstalling. Some of this might not have been necessary, I just wanted to report now it is fixed.

Thanks. Sorry for the inconvinience. That was going to be my next suggestion. Happy to hear !

Question, how do you connect to your local nucleus workstation server after clean installation?
Every time I have to copy the entire old nucleus folder and overwrite the new, empty folder…I doesn’t sound like a correct way to do it.

And does that work well for you ? I know its a manual way of doing it, but I am curious to see if that works and you do not lose data. So you are backuping up your Nucleus folder and then doing a fresh OV wipe ? I will ask if there is an “official” way to back up the folder, but if that works, then great.

When you say “connect” do you mean to authenticate and connect to a fresh local nucleus, or do you just mean to be able to get access to your old files in your backup folder, after you copy the folder back ?