AGX Xavier Shuts Down on First Boot

System Specifications:

  • AGX Xavier Type: 32 GB Developer Kit

  • SDK Manager Version: 2.0.0.1

  • Host Device OS: Ubuntu 18.04 (baremetal)

  • Host Device Type: Desktop

  • Flashed Jetpack Version: 4.6.2

  • Have components other than Jetpack OS is installed: No

  • DC Power Supply Specifications: 12V / 5A

Problem Description:

Hello,

I am trying to install Jetpack 4.6.2 via sdkmanager into AGX Xavier 32GB developer kit. I have downloaded all Jetpack components such as CUDA and TensorRT with Deepstream 6.0.1 as extra and flashed Jetson OS into the AGX Xavier successfully. In order for me to continue on installing these other components like CUDA, I need to do the first boot and initial setup for AGX Xavier. But, when i came to that step, i saw that I couldn’t see anything on the monitor. After checking on AGX Xavier I have realized that it has been shutdown.

Solutions Have Tried:

1. Using UART Serial Console:

Description: I have connected micro USB port of Xavier with USB A Type port of desktop and I have tried both commands:

minicom -D /dev/ttyUSB3 -8 -b 115200

and

gtkterm -b 8 -t 1 -s 115200 -p /dev/ttyUSB3

Result: After using minicom, I saw the output:

agx_xavier_bbot_log_with_minicom.txt (129.4 KB)

Then, tried gtkterm and I did see the output:

agx_xavier_boot_log_with_gtkterm.txt (96.1 KB)

2. Unplugging anything other than Power Supply:

Result: I have seen that Xavier has been shutdown after around 20 to 30 seconds.

3. Using USB C Type As Power Supply:

Description: I have unplugged everything from Xavier and then, connected the USB C port at the back of Xavier to USB A type port of desktop. After connecting, pushed the power button.

Result: Xavier didn’t power up.

4. Using a USB Powered 5 Inch LCD Monitor:

Description: I have plugged DC power supply, HDMI cable and A type end of a micro USB cable to Xavier. Then, I plugged the other end of HDMI and B type end of the micro USB cable to the monitor. Then, pushed the power button.

Result: After a few seconds, the screen powered up and showed NVIDIA logo on white background. Then, the screen turned black and then, after 10 seconds, Xavier shut down.

Could you offer your advice and guidance please?

Kindest regards.

Hi mericgeren,

Could your board work before?
Have you tried to re-flash JP4.6.4 to the board with SDKM?

From your serial console log, it seems kernel has been boot up but something causing power lost so that the serial console log interrupt at the end.

Are you using the official power supply for the devkit?

Hi KevinFFF,

The Xavier wasn’t used before. It’s the first time that Xavier is being used.

I have tried to install JP 4.6.4 with SDKM before. But, i had the same problems with 4.6.4. That’s why i have rolled back to 4.6.2.

Interestingly, power loss doesn’t occur while flashing the OS.

I couldn’t use official power supply. Since, it has been lost and i couldn’t find it.

Kindest regards.

As my understanding, you should use 19V/4.74A for power supply.
Please get another adapter to boot your devkit.

Thank you for the explanation,

for the power supply when i checked the documentation I read that it could be between 9V and 20V. Also, i would like to add that I use Xavier without any peripherals other than a 5 inch USB powered LCD screen. Could you offer your advice please?

Kindest regards.

Yes, the DC input could be 9V to 20V. Not sure about the real capability of your 12V/5A supply, in order to do cross check, please try another more powerful supply as this looks like the power supply capability issue. The power consumption of OS running is much higher than that in flashing.

1 Like

Thank you for all the advice and guidance.

I have tried another supply which can respond better to voltage fluctuations. When I powered Xavier on it booted up and then, opened as it should have. Later, I could do install other Jetpack component such as CUDA Toolkit, TensorRT, cuDNN and Deepstream.

You can close this topic if you would like.

Kindest regards.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.