Another guy with HDMI audio problems

Hey everyone,

I’ve been trying to setup my Jetson with HDMI audio for a few days now to no avail. I did have it working for a little while but I rebooted and lost sound. While pulseaudio shows the HDMI out as one of the sinks, I can’t hear anything through my TV. When I boot up kodi, open up a terminal window, and type in “pactl list sinks”, it says that the HDMI sink is active and not muted. I’ve tested it through both my TV and my receiver but neither works. I’ve also tried launching kodi in ALSA-only mode from terminal but that didn’t work either.

Any help would be greatly appreciated!

I also can’t get audio through my HDMI connection. I’m also pretty new to this whole Linux thing - but I did manage to get the latest Grinch Kernel 21.2.1 installed - Which also involved actually installing ubuntu on a pc - a VM just wasn’t working.

So just to see what would happen, I flashed Tegra for Linux 21.2 (I had been using the out of box version up to that point). Now in pulseaudio and kodi it’s showing three sinks: the default analog output, HDMI/DisplayPort audio, and nVIDIA HDA. Regardless of whether I select either of the outputs, I can’t get any sound output over HDMI. I have also noticed when I run alsamixer, there are two sliders available (HDA Decode Capability and HDA Maximum PCA Channels), neither of which I can increase.

Could you maybe try a different HDMI cable? Or are you sure that the cable is not the problem?