Audio2Face no preview and cuda error


I’m new to Omniverse and trying Audio2Face but I get no preview at all, only black screen.

and I click Get Started in the AI Models panel

the face show up but I got Error

if I play the sample audio or set any parameters in audio2face tool panel, it failed.

[Error] [omni.deform.shared.plugin] OgnSetPoints - Failed to copy 5602 points using CUDA (0x30223e400 <- 0x30222d800)

here is the log
kit_20230901_150621.log (1.1 MB)

I attempted reinstalling it several times, but nothing worked.
What am I doing wrong?

OS : Ubuntu 20.04
CPU : i7-9700
RAM : 16 GB
GPU : RTX 2080
dirver : 470.199.02
cuda : 11.0
cudnn : 8.0.5
audio2face : 2023.1.1

thank you

@arthurwu4work i would suggest looking into the technical requirement/hardware spec for the A2F app specified in the doc. I think 2080 might struggle with A2F in the long run especially if you plan to do any streaming/live sync with another program; but, update the display driver can be the first thing you do.

Hi @Simplychenable ,

I had tried to update the driver to 525.85.05 (the driver version that recommand in the doc)

it still get error, the error log is different this time

2023-09-04 05:51:01 [46,916ms] [Error] [omni.fabric.plugin] Overwriting data in ringbuffer that still had a reference, increase depth to ensure valid data
2023-09-04 05:51:01 [46,921ms] [Error] [omni.fabric.plugin] IStageAtTimeInterval::removeRefCount called for interval with no data

here is the logs
kit_20230904_135014.log (1.0 MB)

I also try audio2face 2022.2.1, it works

Hi @arthurwu4work, can you please updating your driver to a higher version, something along535?

Hi @Ehsan.HM ,

After I update driver version to 535.104.05, I do not get error message from audio2face 2023.1.1.
but when I play the audio, the face does not move

Occasionally, there’s a slight change in the face.

I did not change any parameters, just default setting
here is the log
kit_20230906_171641.log (953.2 KB)

audio2face 2022.2.1 works fine

Can you confirm that Tensor RT build was finished for both A2F and A2G? waiting for a few minutes after loading the stage should give enough time for the Tensor RT to get built.

Hi @Ehsan.HM ,

I have tried to rebuild TensorRT serveral times, but it does not work.
and what is A2G ?

In addition,
I want to use audio2face to build a virtual assitance with Riva such as the 3D AI assitance in youtube (at 1:09)
Is it possible to turn audio2face into a stand-alone PC application with real-time lipsync on TTS ?

thank you

Hi, I’m new to Omniverse too. And I have the same computer configuration as you, but I have had worse luck than you. I have updated my gpu driver to the latest version, I still got error message when I trying to ‘Get Started’. I what to know in addition to installing ‘AUDIO2FACE’ , do you have any other modules installed?

Hi @459250925 ,

I only install audio2face
I follow this doc to reinstall the driver (Q1).
Maybe you could try it.

Thank you for your reply ,I’ll try it.

@459250925 i would recommend making a separate post just in case what you are experiencing is somehow different and would benefit from being troubleshot in a new post. it’ll also make the devs/mods not having to tag multiple people in the same thread or cause confusion.

just my 2c

1 Like

As far as I’m aware A2F is not meant to be used to create another standalone app. But if you’re willing to dive into using A2F in headless mode, or your company meets the criteria to be accepted to participate in ACE, I believe you’d be able to run A2F on cloud.

Please take a look at this video on TTS: Overview of Streaming Audio Player in Omniverse Audio2Face - YouTube