Omniverse Audio2Face Tab not Visible

I installed Omniverse Audio2Face and opened a demo.usd file.
The Audio2face Tab is missing from the right side.
Attached a screenshot:

image

Can you go to the Audio2Face menu (like image above) and click on it and see if you see the Audio2Face Tool menu. See if you can click on that to display the Audio2Face Tab.

It only shows Character Transfer Tool:

1 Like

What version of A2F are you using? The first post you had shows 2021.2.5. Then this one doesn’t show that.

Also can you post the full log? I think if that doesn’t show it could of errored out when the app loads.

Also, just in case pls let us know your system config. Windows version, GPU you are using and driver version. Thanks.

Please find the version details:
image

Audio2Face version: 2021.2.5

Yes, 1809 will not work. Min Windows 10 version requirement is 1909 or above. That is why the Audio2Face part did not load properly. Update your windows and you should be fine.

Sorry to bring back an old thread, but I’m having this same issue. The A2F tab was visible earlier, but after a few launches it has disappeared and there appears to be no way to bring it back. As an additional side-effect, the OmniHydra Dev Settings window is now popping up every time I launch the software.

My system:
Windows 10, version 21H2 (latest)
NVIDIA driver version 512.15 (latest)
Audio2Face build 2021.3.3 (latest)

As a whole, this software seems rather unstable. Reimporting the target mesh consistently breaks the axis that my Mesh Fit nodes are placed on, and I have to restart the software to get the nodes working correctly again. Deleting Audio Players or Data Exports from the Stage Outliner also seems to mess up the entire Audio2Face tab (when it was working), making it impossible to add new A2F Pipelines. A restart is necessary in this case as well.

I’m not sure if this is still in Beta or not, but there doesn’t seem to be any information labelling it as such. These seem like pretty significant issues for a full-release, if that’s the case. I’ll look forward to future improvements, but as it stands I can’t really recommend this for professional use, unless I’m doing something very wrong to be having these issues…?

1 Like

I also lost this window today. Restarted Win10 and I have it again. No other complaints.

@pekka.varis Thanks for this. After starting up my PC again today, the tab is visible again. Still a lot of stability problems but at least this appears to be fixable when it happens.

1 Like

Hello,
I’m on the new Linux version and the tab is missing.
This persist’s through reboots.
It’s also not in the audio 2 face menu.

system: RHEL 8.6
Driver Version: 515.76
CUDA Version: 11.7
Audio2Face build: 2022.2.0

There is an error at startup.

The folder that is missing is the bin folder.

Hi @nic.tanghe ,
I don’t see the error on my side probably due to me using ubuntu vs yours is rh.
from your error, Can you try if this would help ?
find your a2f installation folder and go to the extscache folder/omni.deform.ui/config/extension.toml
and delete line 30-32 like marked on this image


See if you can start A2F after.

1 Like

Hello,

commenting out these lines did not fix anything.
Doing this does yield me the following error.

Is there any possibility switching to RHEL 9.1 for a new kernel and updated dependencies wil fix it ?

Like what version of Ubuntu are you using to run/develop this on ?

THx for the assistance !

PS.
where would I check the logs ? So I don’t have to rush my screencap ?

@nic.tanghe
You can find the log file location form the Settings in Launcher.
Click the user icon on top right corner then open Settings.
image
then click LOGS LOCATION, from there, go to Kit/Audio2Face/2022.2
Please share a couple of the latest ones where you encounter the issue. We should get better idea where the error is.

majority of A2F dev including myself are using Ubuntu 22.04.

Hello,
Below are my logs.

I think seeing as it’s being developed on a higher version of the kernel a lot of dependencies will be higher versions. Seeing my Houdini connector tells me the BLIBCXX is to old. I`ll Update to 9.1 .

Lets hope the houdini`s interface was fixed by now.

part_3.zip (28.8 KB)
part_2.zip (687.3 KB)
part_1.zip (2.5 MB)

Hi @nic.tanghe ,
Yes, the first error message on this log file (I picked part_1.zip\part_1\Kit\Audio2Face\2022.2\kit_20230112_115215.log)

2023-01-12 10:52:20 [4,738ms] [Info] [omni.kit.app.plugin] [4.778s] [ext: omni.audio2face.emotion-104.2.4] startup
2023-01-12 10:52:20 [4,771ms] [Error] [omni.ext._impl.custom_importer] Failed to import python module omni.audio2face.emotion. Error: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.26’ not found (required by /home/nanghe/.local/share/ov/pkg/audio2face-2022.2.0/exts/omni.audio2face.inference_deps/deps/trt-inference-sdk/lib/libtrt-inference.so). Traceback:
Traceback (most recent call last):

After that it’s basically a chain of a2f extensions failed to load due to audio2emotion being failed.
Keep us posted if updating updating your Linux works :)

Wondering if your issue was resolved by updating the libraries?