No results in viewport

I press play in audio player at startup in the audio2face window and there are no results reflected in the viewport. The model loads but will not have lip movement. Trying different audio files did not work.

I can see that I’m connected to the network and that a process time is shown.

Also, sometimes the main camera of the viewport moves by itself along X axis at program launch. This occurs roughly 20% of the time and seems to require relaunching the program.

Attached is a log file of the first issue. I can also include a log file for the camera / viewport moving glitch.

I don’t know if it’s relevant to the issues I’m having, but I could not launch audio2face until I replaced libportaudio64bit.dll as mentioned in the forum FAQ.

Thanks, Evan

RTX 2070 super


kit_20210814_161043.log (273.1 KB)

Hi there, thanks for bringing this to our attention. I’m going to pass this on to the dev team, thanks in advance for your patience.

Hi @kradproductions ,
Thank you for reporting the issue and the log file.
Do you see on the Audio2Face panel that the Building TensorRT message is finished?
Can you share a screen capture of it?

I remember seeing other post in the forum that others have the camera moving on its own.
Do you have controller or other input device connected?
Have you tried other apps like Create or Mahchinima, Do you have the same camera issue on those other apps?


Hi Edy,

I do believe the tensor engine is built. I can attach a screen later tonight when I’m home.

I did in fact have an Xbox controller plugged in when I had the camera error. I have used the machinima app once very briefly and did not encounter the error there. The camera seems to move exclusively left to right along x axis. I will try disconnecting the controller the next time I try and see if that helps.


So I tried a fresh reinstall before I received your reply. Tonight I tried running it and encountered the same non-start issue I mentioned in my original post. I tried the fix of replacing libportaudio64bit.dll again as described in the FAQ and I was able to run the program. Things didn’t seem to load, however: I don’t know how to describe the problems precisely, but attached is a screenshot of what booted for me. Attached is the log file.

Thank you,

kit_20210816_220352.log (156.8 KB)

hi @kradproductions ,
Thanks for the screen shot. Looks like the audio2face UI is not even loaded.

This currently looks to have the same audio lib isse. On the log:

2021-08-17 03:03:57 [4,579ms] [Error] [carb.python] Failed to import python module omni.audio2face.player from c:\users\evan\appdata\local\ov\pkg\audio2face-2021.2.6\exts\omni.audio2face.player. Error: cannot load library 'c:\users\evan\appdata\local\ov\pkg\audio2face-2021.2.6\exts\omni.audio2face.player_deps\deps\py\_sounddevice_data\portaudio-binaries\libportaudio64bit.dll': error 0xc1. Traceback:
Traceback (most recent call last):
  File "c:\users\evan\appdata\local\ov\pkg\audio2face-2021.2.6\exts\omni.audio2face.player_deps\deps\py\", line 71, in <module>
    raise OSError('PortAudio library not found')
OSError: PortAudio library not found

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "c:/users/evan/appdata/local/ov/pkg/audio2face-2021.2.6/kit/plugins/bindings-python\omni\ext\impl\", line 155, in _custom_importer
    return _import_public(folder, module_name)
  File "c:/users/evan/appdata/local/ov/pkg/audio2face-2021.2.6/kit/plugins/bindings-python\omni\ext\impl\", line 114, in _import_public
    module = import_module(module_name)
  File "c:/users/evan/appdata/local/ov/pkg/audio2face-2021.2.6/kit/plugins/bindings-python\omni\ext\impl\", line 65, in import_module
    return importlib.import_module(name)
  File "c:\users\evan\appdata\local\ov\pkg\audio2face-2021.2.6\kit\python\lib\importlib\", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1006, in _gcd_import
  File "<frozen importlib._bootstrap>", line 983, in _find_and_load
  File "<frozen importlib._bootstrap>", line 967, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 677, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 728, in exec_module
  File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
  File "c:\users\evan\appdata\local\ov\pkg\audio2face-2021.2.6\exts\omni.audio2face.player\omni\audio2face\player\", line 1, in <module>
    from .scripts.extension import *
  File "c:\users\evan\appdata\local\ov\pkg\audio2face-2021.2.6\exts\omni.audio2face.player\omni\audio2face\player\scripts\", line 38, in <module>
    a2f_audio = _import_a2f_audio()
  File "c:\users\evan\appdata\local\ov\pkg\audio2face-2021.2.6\exts\omni.audio2face.player\omni\audio2face\player\scripts\", line 34, in _import_a2f_audio
  File "c:\users\evan\appdata\local\ov\pkg\audio2face-2021.2.6\exts\omni.audio2face.player_deps\deps\audio2face-sdk\python/audio2face/audio/", line 2, in <module>
    from .audio_player import *
  File "c:\users\evan\appdata\local\ov\pkg\audio2face-2021.2.6\exts\omni.audio2face.player_deps\deps\audio2face-sdk\python/audio2face/audio\", line 2, in <module>
    import sounddevice
  File "c:\users\evan\appdata\local\ov\pkg\audio2face-2021.2.6\exts\omni.audio2face.player_deps\deps\py\", line 83, in <module>
    _lib = _ffi.dlopen(_libname)
OSError: cannot load library 'c:\users\evan\appdata\local\ov\pkg\audio2face-2021.2.6\exts\omni.audio2face.player_deps\deps\py\_sounddevice_data\portaudio-binaries\libportaudio64bit.dll': error 0xc1

2021-08-17 03:03:57 [4,579ms] [Error] [carb.scripting-python.plugin] Exception: Extension python module: 'omni.audio2face.player' in 'c:/users/evan/appdata/local/ov/pkg/audio2face-2021.2.6/exts/omni.audio2face.player/.' failed to load.

  c:/users/evan/appdata/local/ov/pkg/audio2face-2021.2.6/kit/plugins/bindings-python\omni\ext\impl\ startup_all_extensions_in_module
  c:/users/evan/appdata/local/ov/pkg/audio2face-2021.2.6/kit/plugins/bindings-python\omni\ext\impl\ startup_all_extensions_in_module
  PythonExtension.cpp::startup()(2): <module>

is that libportaudio64bit.dll the one you replaced?
I’ll check with the team if they have any more ideas.

Is this the .dll you grabbed @kradproductions ?

The one I used was linked from the pinned FAQ under “Windows running into this same Assertion Failed issue” that Dimitry linked to in that same thread — not sure if those two are the same, I’m away from my pc right now.

Odd that I could load after replacing it before, but not this time. Will try again tonight.

The two libraries are different. The one I linked is a recent build, so may work better.

I replaced with the zip you linked and it resolved the UI problem as well as my initial problem of not being able to see results in the viewport.

Thank you all for your dedication and timely replies here. I really look forward to seeing what I can do!