Black screen after install of nvidia driver ubuntu

I am having the same problem here… Please helpnvidia-bug-report.log.gz (1.6 MB)

Black screen AGAIN after ugrade to 460. Are you even trying NVidia, to support Ubuntu PROPERLY??? Every update is a jump into the dark, literally. Thank quack we have Time Shift to roll back to a previous restore point. What is causing this issue? Why does the screen turn on ONLY if I connect a second screen? Can you fix this please?

3 Likes

allconfig.txt (6.0 KB)
Please help me!@generix
my current kernel is 5.4.0-62-generic.
my current drivers are Linux-x86_64 / nvidia-460.27.04
my gpu is RTX2080TI
and gdm.log is empty
my error is :
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Hello i have the same problem nvidia-smi is working but my other screen attached to nvidia gpu stays off.
nvidia-bug-report.log (600.3 KB)
help me please @generix
I am working on kali linux

Please run

xrandr --setprovideroutputsource NVIDIA-G0 modesetting && xrandr --auto

to use the nvidia as output sink. You can then run applications on it using render offload:
https://download.nvidia.com/XFree86/Linux-x86_64/460.32.03/README/primerenderoffload.html
https://download.nvidia.com/XFree86/Linux-x86_64/460.32.03/README/randr14.html
Otherwise, you’ll have to configure Prime output:
https://forums.developer.nvidia.com/t/official-driver-384-59-with-geforce-1050m-doesnt-work-on-opensuse-tumbleweed-kde/52620/2?u=generix

I upgraded to 4.60 on Ubuntu 20.04, which resulted again in black screen on Lenovo Legion 7i. The screen turns on only when I connect a second screen. This happened before with other versions of nvidia drivers.
Bug report file attached.
nvidia-bug-report.log.gz (305.8 KB)

There seems to be a compatibility problem with that notebook model:
https://forums.developer.nvidia.com/t/black-screen-after-installing-nvidia-460-driver-on-legion-7i-laptop-geforce-rtx-2070-with-max-q/166584/17
Which driver version was working before?

1 Like

Sorry I can’t be more precise but I think it was 440.

Please update SBIOS to latest release and then try with latest nvidia driver.
Will await for test results.

I’m having an issue with the black screen as well. However, it is only when waking up my computer after it goes to sleep and when my PRIME Profile is using ‘NVIDIA (Performance Mode)’. When using ‘NVIDIA On-Demand’ or ‘INTEL (Power Saving Mode)’ I don’t see this issue. This started happening after an automatic update.

12-01-12_history.log (12.8 KB) nvidia-bug-report.log.gz (403.8 KB)

nvidia-bug-report.log.gz (148.4 KB)

Hi,

Im getting a similar issue, after a fresh install of ubuntu (or any other distro) i cant install nvidia driver because after reboot the system wont launch. im stucked in a black screen with a blinking dash.
i can do ctrl+alt+f2, if i run startx but it says there is no screens found and nothing happens, already try to do X -configure or nvidia-xconfig, already try to delete xorg.conf.
In others distros like pop_os the system starts but only one display work and the app nvidia-settings display a empty window.

@generix Help, please!

motherboard bios updated
2 displays (hdmi/dp)
GTX 1650 super
asus b450 gaming br
ryzen 1600 ( gen 1)

[    7.515106] NVRM: Xid (PCI:0000:09:00): 61, pid=1003, 0d20(31f0) 00000000 00000000
[   11.562354] NVRM: GPU 0000:09:00.0: RmInitAdapter failed! (0x53:0x65:2176)
[   11.562397] NVRM: GPU 0000:09:00.0: rm_init_adapter failed, device minor number 0
[   11.615687] resource sanity check: requesting [mem 0x000c0000-0x000fffff], which spans more than PCI Bus 0000:00 [mem 0x000c0000-0x000dffff window]
[   11.615851] caller os_map_kernel_space.part.0+0x77/0xa0 [nvidia] mapping multiple BARs
[   15.608368] NVRM: GPU 0000:09:00.0: RmInitAdapter failed! (0x24:0x65:1248)

Please try reseating the gpu in its slot, if it still doesn’t work, it’s broken.

1 Like

Hello, I installed Ubuntu 20.04 (last version) alongside Windows 10 as a dual boot.

ASUS ROG Strix Scare G733QS.311.
GPU: RTX 3080 Laptop 16gb
CPU: amd Ryzen7 5800H
I’ve updated BIOS to the latest version before installation.

I have a similar problem as the above’s users - after nvidia drivers installation I can’t launch Ubuntu (I’ve tried with and without parameter ‘nouveau.modeses=0’ in grub).
Steps which I did:
Because system didn’t detect drivers automatically I used ones from PPA repository and it detected one accessible ‘nvidia-driver-460’ :

user@user:~$ nvidia-detector
nvidia-driver-460

so I installed it using Software Updater
When I typed nvidia-smi command directly after installation I obtained this info:

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

So I’ve generated bug report which I attach. nvidia-bug-report.log.gz (367.3 KB)

So I reeboted Ubuntu and when it started booting it froze with the logo of “republic of gamers”. So I used Ctrl+Alt+F3 to go into TTY console - successfully - and I typed nvidia-smi and it showed GPU info:
±----------------------------------------------------------------------------+
| NVIDIA-SMI 460.39 Driver Version: 460.39 CUDA Version: 11.2 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
|===============================+======================+======================|
| 0 GeForce RTX 308… Off | 00000000:01:00.0 Off | N/A |
| N/A 54C P0 34W / N/A | 0MiB / 16125MiB | 0% Default |
| | | N/A |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: |
| GPU GI CI PID Type Process name GPU Memory |
| ID ID Usage |
|=============================================================================|
| No running processes found |
±----------------------------------------------------------------------------+

So I tried to actualize config using sudo nvidia-xconfig in TTY console. After reboot from TTY console the only thing which changed was that black screen with blinking dash in left corner appeared where I wasn’t able to do anything and I was forced to turn off computer using power button…

To run ubuntu I had to purge and remove nvidia drivers from recovery mode. In recovery mode before removing drevier, nvidia-smi command also shows GPU info properly.

I’ve also tried to install drivers by executing a script which I downloaded from https://www.nvidia.pl/Download/driverResults.aspx/170222/pl

Directly after installation I typed ‘nvidia-smi’ command and it showed GPU info properly but after reboot the result was similar as previously - black screen with blinking dash in left corner.

On Windows everything works properly (at least I think so…) so I suppose that is not a broken GPU issue.

I’ll be grateful if You’ll find a solution.
Best regards

lut 13 16:11:28 kaczor-ROG-Strix-G733QS-G733QS kernel: NVRM: API mismatch: the client has the version 340.108, but
NVRM: this kernel module has the version 460.39. Please
NVRM: make sure that this kernel module and all NVIDIA driver
NVRM: components have the same version.

something went wrong with the installation. purge all nvidia packages and install the 460 driver from ppa again.

BOOT_IMAGE=/boot/vmlinuz-5.8.0-43-generic root=UUID=83ea56bc-a159-43ab-82ad-e6b971b31f31 ro recovery nomodeset dis_ucode_ldr

After nvidia driver installation, you should remove the “nomodeset” kernel parameter.

Also blacklist nouveau:

This should give you the steps you need after the installation for the amd/nvidia combo to work:

Also choose your nvidia prime profile.

Thank you for your reply.
Damn - honestly I’ll try to return this laptop to the store… Too many problems with GPU configuration and also with the Asus built-in keyboard which behaves strangely and causes that is useless and I have to put external keyboard (or previously run Windows and reboot and then run Ubuntu - I suppose in Windows boot some keyboard drivers are enabled what is so weird…). If the store won’t agree I’ll try your steps and I’ll let you know the results.

The real problem is:
Ryzen 5xxx
This is brand-new and requires manually upgrading the kernel and fetching firmware. Complete procedure:
https://forums.developer.nvidia.com/t/ubuntu-mate-20-04-with-rtx-3070-on-ryzen-5900-black-screen-after-boot/167681/30

1 Like

OMG! That works! Thank you very much!!! I obtained another small issue - my computer is not able to turn off and I have to use the power button but it’s nothing (at least now)

Does it display anything while hanging during shutdown?

Since you said on the other thread you chose kernel 5.11, I’m not sure the nvidia driver works with that. Please create a new nvidia-bug-report.log.