Black Screen During Booting After I Disabled GUI

I was hoping to make my Jetson orin nano to be a server.
What I did was that I typed sudo systemctl set-default to disable its GUI.
Next time when I booted the device, after the Nvidia logo, it went into black screen and even the fan stopped spinning.

I tried rewriting a new image into my sd card following:, however it booted into the black screen too.

Could anyone help take a look? I guess I need to try recovery mode next, however before that I would like to see if anyone has a solution. Thank you in advance!

Please update to 36.2 for framebuffer console. It’s not supported on 35.X.

You have to re-flash the whole device for it to work with 36.2.
Updating only the SD card image will not work.

Hi Dave,

Thank you for taking a look!
I am a n00b in this area and I am still confused. But if I rewrite a new OS into my sd card, it should not have sudo systemctl set-default option configured, thus it should boot into GUI so why framebuffer matters here? According to ChatGPT, it’s something that can help me display when there is no GPU driver?

Note, the image I wrote into the sd card was already in 36.2. Do you mean 36.2 is not compatible with the old UEFI/Bootloader on my current device that I need to flash with SDK Manager for the whole device?

I bought this device about 3 months ago, and I installed the JetPack 5.1.2, which should have Jetson Linux 35.4.1.

Re-flash the device with 36.2 using SDK Manager, and follow the guide I mentioned.
Nothing complicated here.


Hi Dave, I will definitely try it. But I need to build a host linux machine first in order to install with SDK Manager. Previously I tried using WSL2 but failed.
So a follow-up question is that will install 36.2 update my UEFI/Bootloader?

Don’t use WSL2/virtual machines.
Get a real Ubunt PC.

For sure!
Alternatively, if the 36.2 is not compatible with my old UEFI/Bootloader, will it work if I re-download the old 35.4.1 that had worked?

Supposedly it should work.

I managed to install 35.4.1, and it works! Thank you for the help!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.