Blank screen after installing nvidia 460 driver on Ubuntu 20.04, Quadro RTX5000


I am currently configuring a Dell Precision 7750 Laptop, equipped with a Quadro RTX5000. I have installed the 460 driver with the recommended procedure on Ubuntu 20.04. However, after rebooting, the screen shows only a flashing underscore. Googling around, it seems that this problem has happened before, but none of the solution I found worked. I also tried different driver versions (440, 450) bu the same happened. Following suggestions on the forum, I ran the nvidia-bug-report utility. The output is attached.

Thanks in advance for any help on the subject.
nvidia-bug-report.log (1.5 MB)

Please delete /etc/X11/xorg.conf and remove nomodeset kernel parameter.

Hi and thank you for your answer.

I deleted /etc/X11/xorg.conf, however, concerning the nomodeset parameter, I looked into the /etc/default/grub file and the line is just:
From my understanding, this should mean the nomodest parameter is not present, right?
Unfortunately, even in this configuration, Ubuntu won’t start.

Please create a new nvidia-bug-report.log

Hi and thanks again for the support.
Here is the new nvidia-bug-report.log.
nvidia-bug-report.log (1.5 MB)

Updating the thread in case someone with same problem drops here. After trying to understand the problem a little better, it came up that the problem could be due to some conflict between the Nvidia GPU and the intel one. Since my system does not support Optimus, I tried the opposite suggestion and added the nomodeset kernel parameter. That apparently solved the issue. No idea of the true cause, but that was enough to get the laptop to work for me.

Thanks again for the suggestions.