Building gst-nvarguscamerasrc r35.3.1 source code (potential bug?)


I’m trying to compile gst-nvarguscamerasrc from source because I need to modify the hard-coded gain and exposure time ranges. I cloned the code from and checkouted tag jetson_35.3.1.

To make sure that this build process works, I first ran make and built a new without changing any code. Then I proceeded to put this new .so file at /usr/lib/aarch64-linux-gnu/gstreamer-1.0/ My Jetson Linux version is R35.3.1.

I ran the following command to capture and save a test image:
gst-launch-1.0 nvarguscamerasrc sensor-id=0 num-buffers=1 ! "video/x-raw(memory:NVMM), format=(string)NV12, width=(int)3840, height=(int)2160" ! nvvidconv ! pngenc ! filesink location=test1.png

Then I encountered this error:

This command worked before I replaced the

I noticed that the md5sum of the original is identical to the one shipped in Linux_for_Tegra/nv_tegra/nv_sample_apps/nvgstapps.tbz2 after nvgstapps.tbz2 is untarred by Note: this Linux_for_Tegra comes from the driver package (Jetson_Linux_R35.3.1_aarch64.tbz2) downloaded from the office website.

The new that I built however has a different checksum and it’s much bigger in size.

I have also compared the gst-nvarguscamerasrc source code (r35.3.1) that I cloned with the source code in gst-nvarguscamera_src.tbz2 from the Driver Package source (public_sources.tbz2 for 35.3.1) downloaded from the website. They are identical.

Another thing I have tried was building for R35.1 from the source cloned from and placing it onto a Jetson with r35.1. The gst capture command worked fine.

So is there a bug in the R35.3.1 gst-nvarguscamera source code?


Could you download the source from below instead of clone from the git to check.


I realized that the version of the dependencies very likely matter. I got it to work by building it on Jetson with R35.3.1. And I was building it on another Jetson with R35.1. Also the source code from git and from the downloaded tarball is the same.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.