CAD importer and the importance of hierarchy

Several times when importing large STEP files now, the only thing that has happened is that a folder is created and an USD file is placed in it for every single body in the original STEP file.

I cannot see why this has any use.

From a single STEP file, a single USD file should be generated because the hierarchy present in the STEP file is very important! When the CAD importer ruins that hierarchy, it becomes a great burden to manage the result.

STEP file importing will not have this behavior in the next release and instead it will create a single USD file.

1 Like

I just tried 2023.1.1 and this indeed seems to have fixed! đź‘Ť

However, can I ask a question from a UX perspective:

I barely understand how USD works, since it’s so different to “regular” 3D files, but what I know is that someone will click in the viewport and move objects around… however, that updates a barely human readable transform block on the mesh itself… what’s the best practise here? Don’t you actually want to move the parent xform with the human readable transform when you click on an object in the viewport? What’s the UX thinking here?

EDIT: I also just now noticed that some xforms (with an orange arrow) do have one of those massive transform blocks already with values set for them… but again, since they’re not readable by regular humans and the values don’t show any units, from a UX perspective that’s barely usable.

I’ve seen mention before to “just toggle offset mode”, but I just tried that and used the viewport gizmo to rotate and none of the offset values updated!

Hi EDRobert,
I am not sure what you mean by a human readable transform block. Are you referring to the UI gizmo arrow over the object when selected or the Transform panel ?

This is the transform panel. It works like any other transform panel with Position, Rotation and Scale. The default units are 0.01m or 1.0cm. You can enter specific transform positions, or switch to offset mode.

What I meant was that when you click in the 3D viewport on an object and want to move it, or look at if it has moved, the item with the red arrow gets selected:

(This is the transform I don’t consider to be readable.)

But is it not best practise to do all moves on the item with the green arrow?

(Also, just a nitpick, do you mean that the “Rotate” values are also in cm? Hence why actually writing out the units in the UI itself is important…)

Finally, not sure if this has to do with the CAD importer, but I tried to drag and drop a few glass materials onto the imported model now and as you can see, they all become mirrors instead of see-through…

If you press “T” on the keyboard or use the model select model on the top of the left hand side toolbar, you can switch between selecting the whole model or just the individual prims.

Thanks for all your replies this evening, but we don’t wish to select the whole model (if that means the entire hierarchy), just what’s called a “part” in CAD. However, in that highlighted menu, I see choices for “group” “component” and “subcomponent” and I would have expected the CAD Importer to create those things, but there was no change in selecting behavior when I tried either of them.

Also, pressing T when I tested just now yielded the following graphical glitch, and again no change in selecting behavior:

Screenshot 2023-09-26 211208

Using the T key should change the behaviour of selection for sure. You can even right click on the first icon and bring up a great filtering menu for just selecting what you need.

That menu did work, but again, I did not notice a change in behavior, and the shortcut key you mentioned triggered the visual bug I posted.

What I’m confused about when it comes to selection of what I call a “part” (which I guess is a transform object and a mesh object) is that seemingly this is demonstrated to work as I expect it to in this video at 7:59:

Did he do any setup to get this working, that the CAD Importer doesn’t do automatically when it perhaps should in order to get an equally smooth UX?

If you want to record a video of your selection issue, please do so. I think the main thing is to try to select what you want and then adjust in the stage tree list if not quite correct. I have not heard of anyone else, externally or internally having selection problems. (620.8 KB)

I’m attaching a video here where you can see how the mesh has a transform that is not particularly readable, while the xform where other tutorials seem to indicate should have a transform, doesn’t.

This is a straight CAD Importer result from a STEP file I just did in a new empty Composer 2023.1.1 file.