Fatal error after trying to rename/group some components in STEP imported usd

Hello,
This bug occurs with some components of usd scene imported from STEP file.
When I try to perform rename/group/move operation to this component - program crashes with next output to terminal

2020-11-18 19:17:37 [387,349ms] [Fatal] [omni.usd] Used null prim
2020-11-18 19:17:37 [387,350ms] [Error] [omni.client.plugin]  Main: usd_plugin: Used null prim
2020-11-18 19:17:37 [387,350ms] [Error] [omni.client.plugin]  Main: usd_plugin: Fatal error in void pxrInternal_v0_19__pxrReserved__::Usd_IssueFatalPrimAccessError(const pxrInternal_v0_19__pxrReserved__::Usd_PrimData*)
/data/omni/_build/linux-x86_64/release/isaac-sim-headless.sh: line 4: 10290 Aborted                 (core dumped) "$SCRIPT_DIR/../../target-deps/kit_sdk_release/_build/linux-x86_64/release/omniverse-kit" --merge-config="$SCRIPT_DIR//experiences/isaac-sim-headless.json" --no-window $@

Eventually no crash report being generated for this, as well as i’m unable to find core dump.
Version of isaac-sim-headless is 2020.2.28133

Hi asakhon-AITHEON,

Sorry for my late reply, do you still have this problem?

Kindly,
Liila

Hi @ltorabi, yes, issue is present.

Hi @asakhon-AITHEON, would you be able to provide the output USD that is causing the issue, or provide screenshots showing what prim you are trying to access?

a step-by-step to reproduce the error would be even more useful.

Thank you

Hi, @rgasoto,
Here’s example usd with this issue:
Robot.usd.txt (625.4 KB)
*Remove .txt extension from file
Problematic component here is mt0512p_190430_1_2, if you’ll try to rename or group it - program will crash.
Steps are simple:

  1. Import step file into usd
  2. Try to rename/group component ( it doesn’t appears with all, so it’s better to check with usd i provided)

I’m using isaac-sim-headless 2020.2.28133

@asakhon-AITHEON The USD you provided me is missing the reference USDs. Would you be able to zip the whole yezhik 1.0-01-0001r53 folder and attach it too?

Edit: Removed incorrect suggestions. Suggested solution posted below.

@rgasoto, sure.

yezhik.tar.gz (1.8 MB)
it’s in data/Assets/. after unpacking

Thanks for sharing the other assets. I was able to reproduce your error here.
The problem with renaming/moving the prim is in the physics schema: /Root/mt0512p_190430_1_2 is referenced by the PhysicsJoint /Root/chassis/imu_joint. This crash should be solved in a future release. The best course of action to rename your asset right now would be:

  1. make a duplicate of /Root/mt0512p_190430_1_2 (right click on it on the Stage window, then select Duplicate)
  2. rename/move the duplicate to the intended location
  3. open the relationship editor (Window->Isaac->Relationship Editor)
  4. select /Root/chassis/imu_joint
  5. expand body1, and replace the path /Root/mt0512p_190430_1_2 with the new asset path.
  6. click on Modify in the row you edited.

Please let me know if this solves your issue.

@rgasoto, this is reproducible even with freshly imported STEP, without making any changes to the model if i’ll try to just rename /move it crashes.
I have tried Your solution it was fine to create duplicate and rename it straight after, but if I try to create duplicate -> remove problematic one and then rename -> crash.

I can’t reproduce it with the step files I have, and after updating the joint to replace the reference from /Root/mt0512p_190430_1_2 to the duplicate, I don’t get an error when removing the original prim on your asset either. Remember to only remove the original asset after updating the physics joint.

If you feel comfortable sharing your step file, I’d be interested to try directly from the import process and see if I can reporduce it.

@rgasoto, i can share step with you via e-mail.

But here’s folder with untouched imported model.

yezhik.tar.gz (1.8 MB)

You can find yezhik_1_0_01_0001r53.usd file there, which is actual robot.

Here’s also video of repro: Screencast 2020-12-02 10_57_56.mp4.log (2.0 MB)

@asakhon-AITHEON Unfortunately I was not able to reproduce the segfaults neither from importing the step file you provided me, or from the converted USD.

The video you provided shows as a black screen to me.
I will continue investigating to see if I can reproduce it, in the meanwhile please let me know if the steps from Dec 01 helped unblock you.

Hi, sorry for the late reply, yes workaround is fine, thanks.

I’ve uploaded video to Google Drive, You should be able to see it now