Can i install ubuntu server in jetson nano?

can i install ubuntu server in jetson nano ?

Hi jihantoro,

I can’t answer this question due to never do that before, maybe someone can share their experience.
Just curious, what’s the use case that you plan to do.

Thanks

If the upstream changes in Linux 5.1 that enables support for the Shield TV also allows the Jetson Nano to boot with an upstream kernel, then you probably can. How to set that all up is up in the air though, I don’t know if ubuntu server has a rootfs you can just extract and do the kernel setup manually on.

EDIT: According to kayccc in another thread no, the changes in 5.1 will not work for the nano :(

I would imagine Ubuntu Server is the flavor of Ubuntu nvidia devs would opt for. I was beyond surprised it was Ubuntu desktop.

The purpose of wanting Ubuntu Server is exactly as it sounds. We want it to be a headless unit. My purpose would be to use the board as an NVR to run Shinobi. Shinobi is best run on a headless machine, Ubuntu Server.

While desktop provides many convenient features, majority of it is not needed for a developer or even in production use.

I can say with 100% certainty i will never use libreoffice or chrome on the unit. I don’t even set static IPs from the GUI.

You’ll need to accept that a large number of people who buy this board are going to expect it to allow Ubuntu Server.

Please make an Ubuntu Server 18.04 image. Real developers want Ubuntu Server!

I am just guessing that if you use the boot setup already existing for the official L4T (including kernel and device tree), and if you keep the same Xorg ABI, then the rest of the server setup might work. Possibly systemd/init might require edits.

Actually, since they pull from the same repositories, you can try crossgrading and see if it works.

OTOH if you just want to clean the system up a bit, turn off X, and run the device headless you can:

  • ``` sudo apt purge libreoffice* ``` to purge libreoffice
  • ``` sudo systemctl isolate multi-user.target ``` to turn off X starting on boot.

Then configure ssh to your preferences and you’re done.

fix bug

sudo chown root:root / /lib

clean up

sudo apt purge ubuntu-desktop -y && sudo apt autoremove -y && sudo apt autoclean
sudo apt-get remove nautilus nautilus-* gnome-power-manager gnome-screensaver gnome-termina* gnome-pane* gnome-applet* gnome-bluetooth gnome-desktop* gnome-sessio* gnome-user* gnome-shell-common zeitgeist-core libzeitgeist* gnome-control-center gnome-screenshot && sudo apt-get autoremove

remove unsed programs

sudo apt-get remove --purge libreoffice*
sudo apt-get remove libreoffice-core
sudo apt-get remove snapd lightdm cups chromium*
sudo apt-get remove libcurlpp0

########################

rm -rf Desktop
rm -rf Documents
rm -rf Downloads
rm -rf Public
rm -rf Videos
rm -rf Classes
rm -rf Music
rm -rf examples.desktop
rm -rf Templates/
rm -rf Pictures
rm -rf VisionWorks-SFM-0.90-Samples
rm -rf NVIDIA_CUDA-9.0_Samples

remove sources

cd /usr/src/
sudo rm -rf *
sudo userdel -r ubuntu

would be so much easier (and more practical for automated deployment scenarios) to provide a sensible img download directly