Can we run TensorRT 3.0 on L4T 24.1 ?

I guess L4T 24.1 supports only CUDNN v5. And I have a requirement to run TensorRT 3.0 on 24.1 OS, without updating to Jetpack to 3.3.
For this I did the following steps:
-Copied the dependent TensorRT binaries from Jetpack 3.3 to L4T 24.1 device.
-Copied the libcublas.so.9.0, libcudart.so.9.0.
-Copied the libcudnn7.0 also.
-Compile and Link a sample/samplePlugin with the above include and libraies.
-While Running: I get this error.
ERROR: cudnnLayerUtils.cpp (288) - Cuda Error in smVersion: 35
terminate called after throwing an instance of ‘nvinfer1::CudaError’

I understand that the above is not the right way but still I gave it a try, thinking I may get lucky on TX1, since I was able to run the samplePlugin sample with CUDA 8.0 and CUDNN 7.0, on my desktop machine with Nvidia GTX 1070

But Can anyone help me to update from cuda8.0 to cuda9.0 and >cudnn7.0 on L4T 24.1 OS, so that I can run TensorRT 3.0 ? Is it possible? If not why?

Hi nd-banger,

They are not backward compatible to the older BSP version, all SDKs/libraries have their corresponding versions to get them work when it’s generated/created.

Why can’t move on latest version?

Thanks

So what I can understand is that an OS update is mandatory, for moving to TensorRT 3.0.
We need this because we want a mechanism to update the software on our devices over the air which are running on L4T-24. Recalling all devices is not an option. And TensorRT gives a lot performance benefits.

Hi,

It’s required to update your OS into rel28-2.1 to make it compatible for TensorRT3.0.
Thanks.