Cannot boot from SD card

I recently purchased the NT developer board ( and followed the instructions here (Getting Started With Jetson Xavier NX Developer Kit | NVIDIA Developer). I have a Transcend 32GB micro SD card. I downloaded the image ( and followed the flashing instructions for Apple Mac using Etcher. Note I first formatted the SD card to Extended FAT with a master boot record.

I inserted the flashed SD card correctly. I connected my monitor to the HDMI port and connect the power (I have bluetooth mouse and keyboard). The green light comes on and nothing. Blank screen.

What have I done wrong - or have I a dud card?


Please dump the serial console log.

Those instructions assume one has an Ubuntu PC. I have an Apple Macbook Pro. I tried to replicate the instructions (which do not cover the Xavier NT kit btw so they need updating). I installed minicom but I do not get any new registered serial ports when I connect my micro-usb cable (including removing and reconnecting the power to the board). The thing looks like a dead duck to me. Have you any useful advice to get something out of it without having to dual-boot ubuntu? If not, I will send it back for a replacement. Overall very disappointed with this experience and two wasted days.


How are you connecting your sd card to the Mac? Are you using an external sd card reader?

Have you tried listing partitions on the SD card using something like:

diskutil list external physical

and checking to see if you can find your sd-card and seeing if it has any linux partitions? If not - the card was not imaged correctly.

If you want to make sure the sd card is good you can try to format the card with exFAT, mount it on macOS, and copy some files over. If you can read the files on the card then your card should be okay, and you might want to try and load the image on the card again.

1 Like

Hi acerbix. I have a 2014 Mac so it has an SD slot. I followed your suggestion to format the SD card with exFAT and make sure the Mac can write/read files on it and then I re-flashed it. It worked straight away. First time I just used it out of the box (its a new SD card). many thanks for your great help!