Jetson Xavier NX starts directly to bash - won’t load GUI, can’t get it out of bash environment

Connected to monitor, mouse+keyboard.
completely black display with the following text displayed:
[1.872058] eqos_get_mac_address_dtb: bad mac address at /chosen/nvidia,ether-mac: null.
[1.872314] eqos 2490000.ether_qos (unnamed net_device) (uninitialzed) ether-mac read from DT failed -99
[2.334766] imx477 9-001a: imx477_board_setup: error during i2c read probe (-121)
[2.335048] imx477 9-001a: board setup failed
[2.635918] imx 477 10-001a: error during i2c read probe (-121)
[2.636186] imx477 10-001a: board setup failed
bash: cannot set terminal process group (-1): inappropriate ioctl for device
bash: no job control in this shell

I have tried power cycling 10+ times, and also googling each line typed out and shown in the screenshot
no clue what is happening. Any help is appreciated!
Next things i’ll try are rebooting in recovery mode, or re-flashing the SD card.

For booting from the SD card, I have been flashing the SD on a separate laptop using Balena Etcher, then inserting the SD card and plugging in the Jetson Xavier. Each time I get the above error, black screen with the same problems.

I also tried downloading parallels desktop onto my mac, and connecting a usb cable from my mac to the usb-b (micro usb) port on the Jetson Xavier, then using a linux machine through parallels desktop to run the NVidia SDK manager (Install Jetson Software with SDK Manager :: NVIDIA SDK Manager Documentation) to try to flash the Jetson.
Each time it tried to flash, the following imagee would appear on my laptop screen- where it could not find the Jetson.

Granted, this was done after I already had the error with the black screen and the above error messsages.

I can’t remember if i tried a completely fresh SD card, and tried to use the SDK from linux to flash, or if my SD card had the image or file system that i etched onto the SD using Balena Etcher. Would this make a difference? (do i need to run the software SDK with an entirely fresh SD card, and then flash it from linux + NVidia SDK)?

Thank you!!


  1. The error means rootfs is not able to get loaded from your sdcard. You can try different sdcard or re-download the image again and see if it can work.

  2. If you cannot get around from (1), try sdkmanager. Please put device into recovery mode when you want to flash the board… otherwise it will just tell you the board is not connected.

If you are new to sdkmanager, then you better reading quick start guide from dlc.
sdkmanager can flash the OS only or even flash the OS + installing the SDK (cuda/TRT). Actually, it has nothing to do with sdcard image. When sdkmanager is trying to flash the OS, it will erase the whole sdcard and then re-flash. Thus, what existed on sdcard does not matter.