Cannot connect to Jetson from host pc due to ip address problem

Hi, I am trying to flash Jetson Xavier NX with Jetpack5.0.2 via SDK manager.
I am using MacbookPro2012 clean-installed with Ubuntu18.04 as the host pc.

By connecting the host pc and the Jetson with a blank micro SD card, the host pc recognizes it correctly. However, at Step3, it returns an error stating

“Default ip is not available. Please make sure the default ip is shown in ip addr, or use a customer ip istead”

though the ip addr is filled with the default ip “”.

I tried other ip addresses such as “” and it returns another error

“Cannot connect to the device via SSH. Check the user name and password, and make sure that SSH service is running on the device”

I tried with LAN instead of USB, but it even doesn’t recognizes Jetson.

What should I do?


I think we need to tell the basic of computer network first.

  1. IP will not come up without any reason. The “” IP would only work if the micro usb port is connected between your jetson and host.
    Also your jetson needs to boot up into ubuntu. And your host machine needs to support NCM so that usb device can become a network interface.

  2. If the interface of (1) is not working, then you can use ethernet cable too. Just make sure your host machine can ping the IP of jetson. Give that IP to sdkmanager and it would be able to send the data to jetson…

Hi, thank you for your reply an explanation.
I have a question. Now a blank SD card is inserted to Jetson, but you mean an SD card installed ubuntu is required?


There are two parts of installation of sdkmanager.

  1. Installing the OS. Blanked SD inserted to Jetson will be installed with the L4T OS by sdkamanger.

  2. Installing the SDK (CUDA/TensorRT… etc). After (1) is done, or any case that your L4T OS on jetson is already booting up, then you can give the IP to sdkm and it will install the SDK.

In (1), there is totally no IP in that stage (because no software running for it), so the IP is for (2).

1 Like

Just wanted to add some info in case it helps clarify the procedure: If you got to the part about IP address, then flash actually succeeded, and it is at a stage where it wants to add optional software, e.g., CUDA. During flash the Jetson is in recovery mode and does not use networking, but upon completion of actual flash the Jetson will self-reboot. This is when it wants the address. You don’t need to flash again if it ever got to the stage of requesting either account setup or network login (you can add extra software later by unchecking flash steps and unchecking any software you don’t care to install, e.g., optional software on the host PC itself).

If it turns out the Jetson rebooted, then you won’t be able to use networking until first boot login setup is completed (either on a local monitor or over serial console…serial console is a wonderful thing for the embedded world, and I often wish I had it on PCs during boot stages). The use of ssh to install software requires the account to be set up, combined with networking.

If the account setup is completed, and networking fails, then it won’t be because flash failed, and it won’t be because the Jetson did not boot correctly (you would not have been able to complete first boot account setup had boot failed). In that case, then it is likely either the incorrect USB cable is connected (the NX format Jetsons use the micro-B USB cable, some newer Jetsons use USB-C), or else the host PC simply needs to be told to allow the connection (sometimes security is set up such that the host PC won’t accept a network device on USB without an ok).

Did you see first boot account setup in either a local terminal on the Jetson, or via serial console? If you don’t know, then I highly recommend trying to use serial console (it is just the micro-B USB cable in combination with running a serial console program on the host PC, and this works even if the Jetson’s graphical mode is dead).

1 Like

@WayneWWW and @linuxdev
Thank you very much for your supports.
Finally, by selecting Manual setup instead of Automatic setup at Step3, I succeeded.
What I needed was to turn off force recovery mode before flashing.

The implication is that install was past the “flash” stage and simply installing optional packages, e.g., CUDA. Sometimes the installer software is confusing because it isn’t clear that flashing and optional packages are actually separate even when performed in the same installer GUI.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.