Cannot find CUDA after installing Jetpack 5.1.1 from SDK Manager Jetson Runtime Components only on NX Board

I successfully installed the runtime SDK on NX Board however, faced the CUDA and Opencv issue while loading through terminal.
Also the default python is 2.7.18.

This is the forum for the older TX1-based Nano. You should probably move this to the correct NX forum, but I don’t know if you are using an Xavier NX or an Orin NX (URLs are for those forums).

Sorry for not mentioning full information. I have posted the above question on Xavier NX Board forum but no response. . I am talking about Xavier NX 16GB Board.

Duplicate to topic 253172:

Let’s continue the discussion there.

I successfully installed the runtime SDK on Xavier NX 16GB Board however, faced the CUDA and Opencv issue while loading through terminal. Here are some of things which i tried so far:

$ apt show libopencv-python
Package: libopencv-python
Version: 4.5.4-8-g3e4c170df4
Priority: optional
Section: libs
Installed-Size: 12.0 MB
Provides: python-opencv
Depends: libopencv (= 4.5.4-8-g3e4c170df4), libc6 (>= 2.17), libgcc-s1 (>= 3.0), libstdc++6 (>= 9)
Conflicts: python-opencv
Replaces: python-opencv
Download-Size: 3,201 kB
APT-Sources: r35.3/main arm64 Packages
Description: Open Computer Vision Library
 Python bindings for Open Source Computer Vision Library

Also the $PATH and $LD_LIBRARY_PATH in .bashrc is configured properly however there is no bin folder in /usr/local/cuda-11.4.

can you please assist me in solving this issue? I have re flashed Jetson Linux and reinstalled the runtime components but gives me same result.
Please check the attached SDK Manager log file.
SDKM_logs_JetPack_5.1.1_(rev._1) (228.7 KB)

I can’t tell you about the missing software, and the other topic would be preferable to duplicate posts. However, I will suggest that sometimes python3 is required, and at other times python2 is required. Consider naming those explicitly.

Note these commands:

  • which python
  • which python2
  • which python3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.