Cannot find U2D2 in Jetson Nano


I’m building my robot, and I want to control Dynamixel Servos XL430 by U2D2 on Jetson Nano, but when I connect the U2D2 and Jetson Nano with a USB cable, there is no information about U2D2.

I tried using lsusb:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 008: ID cce3:3884
Bus 001 Device 007: ID 0bda:c811 Realtek Semiconductor Corp.
Bus 001 Device 003: ID 1a40:0801 Terminus Technology Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

As you can see, there is no U2D2 device. The device 008 is my webcam.

I am sure that when I test on my windows computer, it works well.

Anyone can help me? Thank you!

Could you plug in your usb device and check if the dmseg prints out any new log?

Thank you for your advice. I just checked log infos with dmesg. And I found the problem that my power supply is not sufficient, then I switched from it to another power source. Now it works.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.