Cannot output usd file


windows11
houdini 19.0.657

Hello @cmx278171032! Without a log file, it looks like it is not able to connect to your localhost path. Can you go into your content browser and right-click on your localhost server and click “Reconnect”?

server

You can check your connections by going the Nucleus Tab on the Omniverse launcher, clicking the “hamburger” icon and choose Settings. Make sure all of your Nucleus services are running. You can click on the “Restart All” icon to re-launch your services.


Let me know if this helped, if not, can you let me know what errors you ran into. And also attach a copy of your log files for Houdini found here: C:\Users\<USERNAME>\Documents\Omniverse\<CONNECTORNAME> Also, to be safe, if you could go to C:\Users\<USERNAME>\.nvidia-omniverse\logs\System Monitor and attach that log here as well!

I will also need to know your current system environment. Operating System, GPU / GPU Driver.

MAYA works fine
Houdini log is empty
logs.txt (25.6 KB)
Houdini.7z (20.7 KB)


516.93-desktop-win10-win11-64bit-international-nsd-dch-whql
Windows 11 PRO 1000.22000.675.0

found a bug
when i click ‘SAVE TO DISK’
20220803095955
20220803100005

The native Houdini Save to Disk for hip files to an Omniverse Nucleus server does not work using the native Houdini FS, known limitation in the docs. However, there is a Save Hip shelf button and menu option in the Omniverse menu as a work around.

the error when I click ‘USD_ROP’ ‘save to disk’
not save hip
when i click just quit houdini

Hello @cmx278171032
Thanks for reporting this. Could you try a couple things for me, please?

  1. Uncheck “Error Saving Layers With Implicit Paths” toggle under “Extra Files” on USD ROP
  2. Uncheck the Pre-Render Script or remove the “q”
    from The Pre-Render Script parm

The first option is a feature that Houdini has specifically, and that’s why you don’t see it in Maya.
From Houdini’s Doc USD (sidefx.com)

  • Error Saving Layers With Implicit Paths
    When this is on (the default), the node errors if it would otherwise write an anonymous in-memory layer (that is, a layer with no file path metadata) to disk.
    You will usually only turn this off if you are using the Save style “Separate layers” to write out every layer separate for debugging purposes.

There are several ways to get around this issue, easiest one is uncheck the toggle like I suggested above. You can also config where to save the layer by using a Configure Layer (sidefx.com) LOP. The other way is to change the “Save Style” to “Flatten Stage” on the USD ROP if you don’t need to preserve references and sublayers.

The other issue I notice is the Pre-Render Script. The “q” will quit Houdini before writing out any data. I think it was accidentally put there?

Please give the suggestions above a try and let me know if that works for you. I am happy to help if you are still experiencing the issues.

thanks
But still not working


But ‘filecache’ node is working !


Hi @cmx278171032
Thanks for trying that. I have tested similar steps on my end and the USD ROP created the directories and wrote out the files correctly.
I know we have seen similar issues of creating directory on Nucleus in Houdini, and we are working closely with SideFX to sort out the issues. This might be one of them.
If you don’t mind, could you try something more for me, please?

  1. Restart the Houdini session, sometimes Houdini have the errors lingering on the node and that might cause some misleading info.
  2. Check the files on Nucleus, tho Houdini says cannot create path to write files, but the files might have been written.
  3. Create the folder on Nucleus first before writing out USD files. For example- create ./geo/obj/geo1/ folders then write out USDs as a temp workaround.

If all of above don’t give you a good result, we are working a new Connector for H19.5 and have directory creation bug fixes coming soon.

Again, thank you for using Houdini Connector and report the issue. Please let us know if you have more questions and feedback. We love hearing from you.

Still not working,but reduced one error message
And I also created the matarial folder, referring to the structure of the local USD file


20220804170908

Hello @cmx278171032
Thanks for testing that again.
I have tested other setups and still cannot reproduce the issue. There are a few things we can try more,

  1. If you use the same USD ROP, and change the output path to somewhere local (e.g. C:\). Does it work?

  2. If above works, then could you try change the output path to another omniverse:// path (e.g. omniverse://localhost/testProjects/). Does it work? (Wondering if there are permission issues.)

  3. If none of above works, I suspect the original fbx file that attached in the hip you provide (E:/Project/2022.8.2_CAM_MEMO_USD/geo/PURE_CAM.fbx) might have a problem?

hi walai,thanks for you reply!
Test 1-working
Test 2-not working same error log
Test 3-Even a sphere create by Houdini ,not working same error log
Test 4-Try running Houdini with administrator,not working same error log
(eg,Is it possible because my system language is Simplified Chinese?)

Your Omniverse path doesn’t contains any Chinese characters, so it should be ok. I need to test it with Windows 11 system.
I will update here again once I found the issue.
Thank you for your patience @cmx278171032

Wayne

Upgraded to version 101.0.0, still not working
and ‘Omniverse Loader HDA’ ‘Omniverse Validator HDA’ node cannot be found
20220812095815
20220812095914

finally!windows10 solved the problem!
windows11 not working!pls fix!

Hi @cmx278171032 ,

We’ll keep investigating to see why the Win10 worked and Win 11 did not. Our testing with Win 11 so far have not reproduced the issue.

As for the loader and validator nodes will be in the next release. We decided to hold off on them for now, release notes should be updated shortly.

Thank you for your feedback and if you find any other issues please let us know. And if you have anything you can show off post that too!

Best,
Kevin