Can't load omni.physx when running Create


I’m trying to enable Omniverse Visual Debugger to debug my Physx application. But for some reason, when running Create app, the omni.physx plugin fails to load.

(Note that I have tried with 2022.3.3 and 2022.3.1 versions and both gave me the same error)

You can see the log output in the creator.log attached file. And the console log I can’t attach since I’m a new user and it only allows to upload one file for new users. But more or less had the same info.

I believe this is the relevant first error:

[4.535s] [ext: omni.physx-104.1.6-5.1] startup 2023-05-29 09:04:08 [4,481ms] [Warning] [carb] [Plugin:] Could not locate the function: carbGetFrameworkVersion
2023-05-29 09:04:08 [4,481ms] [Warning] [carb] Potential plugin preload failed: /home/lpares/.local/share/ov/pkg/deps/82b461274b877b7d5e1a405066cfd47a/extsPhysics/omni.physx-104.1.6-5.1/bin/
2023-05-29 09:04:08 [4,481ms] [Error] [omni.ext.plugin] [ext: omni.physx-104.1.6-5.1] failed to load native plugin:

I’m running it in Ubuntu 20.04, with integrated Intel graphics.

Any help will be appreciated!

console.log (1.1 MB)

there is a bug that prevents omni.physx to start when no Nvidia GPU is found, sorry about that. We have a fix for the upcoming release, where omni.physx should be able to start without Nvidia GPU.
You should be still able to use the old PhysX Debugger:


I see, any ideas when this next release will be? Is it possible to use it as a beta version somehow?

As for the PhysX Visual Debugger, I can’t find any download link for Linux. Is it only available on Windows?

Thank you!

Yes, sorry thats Windows only correct. If you have some windows machine you can run it there and setup the PVD connection to that machine.

Next release should be out within a few weeks.


1 Like

Any ideas when the newer version will be available?

Still a couple of weeks sorry

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.