Failed to create GPU for compatibility mode

Hi Everyone,

I use to have one RTX A4000, and it was working fine. I added a second RTX A4000, updated the driver to the latest, and now I can’t open any application from the Omniverse Launcher anymore. I get an error message “Failed to create any GPU devices for compatibility mode”.

However, according to the NVIDIA control panel, both my GPUs are up and running.

I am on Windows 11.

Any idea on what is happening?


@romichel2003 i am just another OV user, would it be possible for you to upload the launcher.log for eval? perhaps there are additional information that could facilitate troubleshooting process.

%userprofile%\.nvidia-omniverse\logs\launcher.log

Hi @Simplychenable
Here is the launcher. Yesterday was the first time I tried to open an Omniverse application, so only the data from 2024-01-31 13:22:05.077 to 2024-01-31 22:00.
I am using the latest one (R550).
launcher.log (846.4 KB)

is this on a personal machine or part of a enterprise equipment? can you try a few things? one thing i am trying to determine is whether you have file/folder access permission issue. if it’s an office equipment, check with your IT to make sure configurations are all proper. could you also confirm again if the apps you have installed are all having the same problem (Blender, Code, Create XR, and Composer) or just Composer?

  • relogging - log out of the OV launcher and log back in. better yet, reboot your machine if you haven’t since the Launcher installation.
  • deleting kit files - close out of all OV related apps including the Launcher, then navigate to C:\Users\Rosaire\AppData\Local\ov\data\Kit and delete all the subfolders and their contents from that directory.
  • GPU driver clean install - try reinstalling the display driver again but this time do a clean install. you should see that option in the installer.
  • update the .bat file to force multi gpu - open to C:\Users\Rosaire\AppData\Local\ov\pkg\create-2023.2.2\omni.create.bat and edit the file to look like the snippet below:
@echo off
setlocal
call “%~dp0kit\kit.exe” “%%~dp0apps/omni.create.kit” %* –/renderer/multiGpu/enabled=true

i see some errors regarding network disruption but i am unsure if it’s related to the GPU issue. let’s try the two options first and see what happens. also, what’s R550?

Thanks for your inputs.
I am using a personal machine. The problem is with all OV apps, except Blender 4.0
I tried the all the points you listed with no success. Here are the logs
log_forcing_multigpu.txt (8.6 KB)
crash_2024-02-02_08-57-14_15468.txt (6.1 KB)

There is seems to be an issue with a plugin (carb.graphics-direct3d.plugin), but i have no idea if it is the cause or the consequence of the issue I am facing.

there’s another line from the log that stood out for me:

[carb.graphics-direct3d.plugin] Aftermath D3D12 failed to initialize.

and in the crash log, it reports:

[crash]  aftermath_version = '2022.2'

i will defer to the mods/devs on this because they will certainly know more about the technical aspect rather than me speculating.

i am facing same problem with usd composer and Omniverse Machinima work fine


mine .i am using [

NVIDIA GeForce RTX 2060 is my graphics card is not compitable or there is some problem with omniverse usd composer ?

I faced the same problem but I have an rtx 3060ti video card
Can you help solve the problem?


crash_2024-02-24_15-30-44_836.txt (7.1 KB)