Help! Renderer won't initialize

I am very excited to try Omniverse Create! However when I start it up I get a bunch of errors with the line “but no renderer was initialized”. I have attached the log and system profile. I have 2x 2070S which I think are compatible but I am wondering if the 1080Ti is throwing things off. I have tried both 460.89 and 456.71 drivers with no luck. Thanks for any help anyone can give!

kit_20201216_004801.log (176.5 KB)
system profile.txt (891 Bytes)

To use only the two 2070s in your setup, please try launching with --/renderer/multiGpu/activeGpus=0,2. I took these indices from the system info table in your log file.

There is no UI yet for editing command line options, so you have to do it manually:

Next to Create’s Launch button click on the stack icon and then Settings. There you can click on the folder icon next to the install path, which will open up the file explorer with a bunch of startup scripts.

You can edit the omni.create.bat file and append the setting --/renderer/multiGpu/activeGpus=0,2 to the call. Then just double click the bat to launch.

Thanks for your valuable feedback! We’ll work on improving automatic multi-GPU detection.

1 Like

@tbiedert Hello

I am getting a bunch of errors in my log as well. However, my viewport just looks like a grey box. I have a latop with 1080 gpu with a external gpu of a 2080. I have tried both 460.89 and 456.71 drivers How should ifix this?


kit_20201216_090655.log (195.1 KB)

@megaoutput Please try running the omni.create.singlegpu.bat that you can locate as outlined in my post above. This should automatically pick your 2080 then.

Thanks so much! However when I went to try this today for some reason the Omniverse Launcher appears as a resizeable grey box no matter how many uninstalls/reinstalls/ 460.89 or 456.71 drivers/output GPUs I use (screengrab attached). Really sorry to be a bother but I am totally confounded. Everything else on my system works swimmingly in heavy GPU use so I am wondering what I can do to reinstate the Omniverse Launcher GUI and try the solution you recommended! I really appreciate any additional tips you can give! Thanks @tbiedert!!!

@Emberblend Please share the launcher log file, which should be located at .nvidia-omniverse\logs\launcher.log. Thanks!

@Emberblend The gray launcher window can happen when you update the driver while the launcher is running. Try exiting the launcher via system tray (not just closing the window) and re-opening it.

1 Like

I was just going to reply that the issue had gone away! It did involve some force quitting of background processes etc so I think the same thing was achieved.

I appended --/renderer/multiGpu/activeGpus=0,2 as you recommended and everything worked great! Thanks so much for your attentive help @tbiedert. You have made this somewhat technologically limited artist happy!

1 Like

I also want to note that the renderer still fails if I use the 1080Ti as my display output. I am not surprised as this is consistent with other real time solutions. I just thought I would note this for anyone else reading or in case its something devs do want to tackle as its something of a norm in parallel industries to have a dedicated “Display GPU” that wouldn’t be used for heavy lifting.

Good suggestion! Please provide the log file of such a failed run when you pick the 1080Ti as display output.

Can you clarify what exactly you mean by “picking as display output”? I assume you mean having the display attached to that card?

Here is a log when I open via the edited omni.create.bat with my display attached to the 1080Ti (you correctly guess that is what I mean by “picking as display output”. Thanks for your openness to suggestions!

kit_20201216_140706.log (168.5 KB)

I think the issue is that the 1080Ti is a GTX. Omniverse requires a RTX device.

Thank you @mirice! I totally understand Omniverse is RTX only and @tbiedert has helped me configure the startup file to utilize my 2x RTX 2070 S cards. In this case I was only referring to using a 1080Ti to drive my display while using 2x RTX 2070 S as my render cards within Omniverse. Thank you for making sure I am informed!

1 Like

Click on the file and boom.
just wanted to let you know it worked perfectly thanks!!!

1 Like