OV Create defaults to UHD and does not use an RTX GPU

Hi there!
I am trying to run Omniverse Create on my Razer Blade 15 laptop with an RTX 2060 GPU. However, when I open it after a fresh install, the “RTX Loading” message never goes away, and in the corner of the viewport I can see “Intel(R) UHD Graphics 630”, which tells me that for whatever reason Omniverse is using the default integrated graphics chip, as opposed to the available RTX GPU.

I tried explicitly setting a default graphics card through the NVIDIA Control Panel, but sadly OV Launcher is the only application that’s listed (I guess OV Apps such as View or Create don’t get registered as standalone Windows applications). So is there a way to point Create to a specific GPU?


Thank you for posting. Yes we have seen this before. I will confirm a solution and get back to you. Have you tried to disable the Intel Graphics card in Device Manager ?

Hi! Thanks for the prompt reply.

So, when I disabled my integrated graphics card, things got even weirder: Create wouldn’t launch at all. I click the “Launch” button, the splash screen appears for a brief moment, then it goes away, and… nothing.

Immediately after I re-enabled UHD, everything went back to normal (Create launches, but the viewport is stuck at “RTX Loading”)

Ok. understood. In that case then, try changing your default GPU settings “per app”. See below.

Seems like it’s using UHD regardless

And this is the path to exe


Can you try this as well ? You have to make sure you are in “High performance mode” and then make sure that you are setting your NVIDIA card for HPM

Sadly, this didn’t help either. Here’s something else I’m noticing. I installed Omniverse on our office workstation with two RTX A6000 GPUs (there it works perfectly fine, I took this screenshot while RTX was still loading). When I look at the top right corner, I can see both RTX GPUs at once. When the scene finished loading, the first GPU got highlighted, which I guess means that this is the GPU I am using. But the important thing is that I could see both GPUs at all times, regardless of which one is used. In my laptop’s case, however, I don’t see the RTX card at all. So I wonder if Create is just unable to see my 2060 for whatever reason.

Yes you are supposed to see all of your cards, all at once, regardless of use. In this case, we can try to force on all cards in the system, by enabling MGPU at startup by adding “–/renderer/multiGpu/enabled=true” to the command line, or in the .bat file

No luck :/

(I tried both --/renderer/... and -/renderer/...)

No luck meaning you could only see one card in Create ? Hmm, this is quite strange. Can you provide the specs of your system.

Can you also try downloading VIEW and try that. Also can you roll back Create to the previous version ? Something seems incorrect here.

Yup, still only one card displayed. Here are the specs:

Host Name:                 <redacted>
OS Name:                   Microsoft Windows 11 Home
OS Version:                10.0.22621 N/A Build 22621
OS Manufacturer:           Microsoft Corporation
OS Configuration:          Standalone Workstation
OS Build Type:             Multiprocessor Free
Registered Owner:          <redacted>
Registered Organization:   Razer
Product ID:                <redacted>
Original Install Date:     1/27/2023, 12:52:52 PM
System Boot Time:          3/13/2023, 9:14:15 PM
System Manufacturer:       Razer
System Model:              Blade 15 Mid 2019-Base
System Type:               x64-based PC
Processor(s):              1 Processor(s) Installed.
                           [01]: Intel64 Family 6 Model 158 Stepping 10 GenuineIntel ~2601 Mhz
BIOS Version:              Razer 1.03, 6/6/2019
Windows Directory:         C:\WINDOWS
System Directory:          C:\WINDOWS\system32
Boot Device:               \Device\HarddiskVolume8
System Locale:             en-us;English (United States)
Input Locale:              en-us;English (United States)
Time Zone:                 (UTC-05:00) Eastern Time (US & Canada)
Total Physical Memory:     16,282 MB
Available Physical Memory: 7,728 MB
Virtual Memory: Max Size:  18,714 MB
Virtual Memory: Available: 7,673 MB
Virtual Memory: In Use:    11,041 MB
Page File Location(s):     C:\pagefile.sys
Domain:                    WORKGROUP
Logon Server:              <redacted>
Hotfix(s):                 5 Hotfix(s) Installed.
                           [01]: KB5022497
                           [02]: KB5012170
                           [03]: KB5022845
                           [04]: KB5022610
                           [05]: KB5022948
Network Card(s):           <redacted>
Hyper-V Requirements:      A hypervisor has been detected. Features required for Hyper-V will not be displayed.

And the GPUs:

Intel(R) UHD Graphics 630
NVIDIA GeForce RTX 2060

Also, downgrading Create to 2022.3.1 makes no difference (still just one card) and View simply doesn’t show anything:

I am not sure what further we could do to help. This all should be working fine. Can you be sure that your GeForce card works well in other rendering applications? it seems in a matter what we try, your GeForce card is not being used. What are the rendering applications do you use?

I would like you to update the GeForce driver. Also update the Intel driver as well if one is available. See if that makes a difference.

Can you send me a log file so we can take a look. Thanks.

One more thing to try. Add this code either to the cmd prompt or the bat file directly. “–/renderer/activeGpu=1”. Try 1 and if that does not work try 0.

The good old “wash your hands, eat your veggies, and keep your drivers up-to-date” haha. Everything works now out of the box with no need for additional cmd arguments. I don’t know why I didn’t think of this earlier. Thank you very much for your help!

Ok good. Yes I also should have mentioned it earlier. I did assume you had tried new drivers. Well glad it is all ok.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.