Omniverse Create crashing on launch

hi, i download create 2022.3.3 but can’t launch, i tried other versoins but the result were same.
I also tried omniverse issac, it can launch. omniverse code can’t launch.

the situation is smiliar with the link below, but my colleague use the same laptop and he could launch create, so our IT thought crashing was not cause by their setting :

The log file is also attached:
kit_20231017_091815.log (248.9 KB)
kit_20231017_092340.log (265.2 KB)

my laptop params are :
12th Gen Intel(R) Core™ i7-12800H 2.40 GHz
16.0 GB RAM
RTX A1000 laptop GPU

thank you for help i am just another OV user, but is it possible for you to upload the OV Launcher log file as well? you can find it here: C:\Users\%username%\.nvidia-omniverse\logs\launcher.log

hi, here is the log
[2023-10-20 16:20:53.332] [debug] Running “C:\Users\\AppData\Local\ov\pkg\create-2022.3.3\omni.create.bat”
[2023-10-20 16:26:43.767] [debug] Running “C:\Users\\AppData\Local\ov\pkg\create-2022.3.3\omni.create.bat”
[2023-10-20 16:40:55.008] [info] Omniverse Launcher 1.8.11 (production)
[2023-10-20 16:40:55.015] [info] Argv: C:\Users\\AppData\Local\Programs\omniverse-launcher\NVIDIA Omniverse Launcher.exe --hidden
[2023-10-20 16:40:55.016] [info] Crash dumps directory: C:\Users\\AppData\Roaming\omniverse-launcher\Crashpad
[2023-10-20 16:40:55.119] [debug] Running “C:\Users\\AppData\Local\ov\pkg\cache-2023.1.0\System Monitor\omni-system-monitor.exe”
[2023-10-20 16:40:55.134] [debug] Reset current installer.
[2023-10-20 16:40:55.187] [info] Running production web server.
[2023-10-20 16:40:55.202] [info] HTTP endpoints listening at http://localhost:33480
[2023-10-20 16:40:55.209] [debug] Sharing: false
[2023-10-20 16:40:55.250] [info] Started the Navigator web server on
[2023-10-20 16:40:55.884] [info] Registered omniverse-launcher for Windows.
[2023-10-20 16:40:55.888] [info] Registered omniverse for Windows.
[2023-10-20 16:40:56.468] [info] Logged in.
[2023-10-20 16:41:10.266] [debug] Running “C:\Users\\AppData\Local\ov\pkg\create-2022.3.3\omni.create.bat”
[2023-10-20 16:51:28.672] [debug] Running “C:\Users\\AppData\Local\ov\pkg\code-2022.3.3\omni.code.bat” --/app/environment/name=‘launcher’

and i go to check event viewer, there is one application error.
fail application path : c:\users\\appdata\local\ov\pkg\create-2022.3.3\kit\kit.exe
fail module path : c:\users\\appdata\local\ov\pkg\create-2022.3.3\kit\kernel\plugins\

just curious - which other versions of Composer have you tried?

i randomly chosed some Release versions (like 2022.3.1) and even some Beta versions, but they all fail to launch.

RTX A1000’s 4GB VRAM feels a bit low for Composer, but i’ll let @Richard3D to confirm. do you mind disabling the intel display driver via the device manager window (you should see both RTX and the intel UHD) and try again?

still same result. but thanks for any advices : )

i am trying to rule things out one by one so thanks for the patience!

based on the log, Composer seems to be terminating during the splash/loading screens (where it showed some rendered images), correct? if not, can you elaborate a bit more about when the crash occurs? did you ever see the app window show up at all, for example, or how long into the load does it crash for you?

I have your logs and I can see where you are crashing. I will get back to you. I personally think that the RTX A1000 is not enough power for this application. It is well below min specs. We recommend at least 12GB. 8GB bare min.

1.Composer seems to be terminating during the splash/loading screens is correct.
2.Did not have any app window show up
3.The loading time i think is about 5-10min, long enough. My colleague’s launchable laptop is abot 30 sec to launch create.

Thanks for your reply, but I saw other same type laptop use RTX A1000 can launch it. Does the GPU affect launch situation? I haven’t load any file yet.

“.The loading time i think is about 5-10min, long enough. My colleague’s launchable laptop is abot 30 sec to launch create” Either way, you are both running very low memory cards. Maybe he has more hard drive space, or more modern drivers. There are many factors. It should not take more than about 30 seconds to start on anyone’s machine. If it does, there may be something wrong with your system. Nothing in the logs indicate anything specific. Just a hard system crash, which is usually from the gpu. Even if it did not crash, there is not much you can do on a 4GB system. Even 8Gb would be tough

thanks for reply. I reinstall composer and can provide more information(but still can’t launch)

  • It takes 15 min to install USD composer 2022.3.3 from exchange, and seems stuck in download OMNI.create.warmup.bat for 6 min, not sure if it is normal
  • In the last two minute in download process, the event viewer shows error messages:
    fail application path : C:\Users\\AppData\Local\ov\pkg\create-2022.3.3\kit\kit.exe
    fail module path : c:\users\\appdata\local\ov\pkg\create-2022.3.3\kit\kernel\plugins\VCRUNTIME140.dll

just out of curiosity, what were your OV installation paths (data, cache, and content)? are they all pathed to your local drive? if the paths are located on an external hard drive, are the drives HDD or SSD?

the reason why i am asking is because i have experienced a long load time (15-20 mins) when my paths for all three were mapped to external drive (and maybe something to do with the USB cable i had). after defaulting my paths back to local, launch was snappy (10-15 secs). it may not pertain to your case, but just wanted to share my experience.

i think i know what the result of this will be, but do you want to try running the .bat file located here to see if the behavior changes? C:\Users\\AppData\Local\ov\pkg\create-2022.3.3\omni.create.bat

I used default OV installation paths, and all in disk C. disk C is SSD(299GB, remain 210GB).
about running omni.create.bat, here are the launchable log and unlaunchable(my laptop) log.
successed.txt (21.4 KB)
failed.txt (106.5 KB)

This may be an issue “”. It is a really bad idea to have any special characters in your main windows name. I am not sure how windows even allows it. It would be better being “jerry”. You should not have “.” in a system name. I have seen issues because of this before.

You may want to make a new windows user profile called “Test” or “Jerry” and try all of this again.

I figured out where cause the problem. I switch the SSD of launching successed and filed laptop, and the result become opposite. So It seems like hardware quality problem.
thanks for “Simplychenable” and “Richard3D”'s help, and I hope my situation can give you a good reference

1 Like

Great thanks