Can't run any example on SDK All exemples stuck at cuda instruction

When I run deviceQuery on my machine I get:

There is 1 device supporting CUDA

Device 0: “GeForce 8400M G”
Major revision number: 1
Minor revision number: 1
Total amount of global memory: 133496832 bytes
Total amount of constant memory: 65536 bytes
Total amount of shared memory per block: 16384 bytes
Total number of registers available per block: 8192
Warp size: 32
Maximum number of threads per block: 512
Maximum sizes of each dimension of a block: 512 x 512 x 64
Maximum sizes of each dimension of a grid: 65535 x 65535 x 1
Maximum memory pitch: 262144 bytes
Texture alignment: 256 bytes
Clock rate: 337500 kilohertz

Test PASSED

But when I run any example in the SDK it stucks at the first cuda instruction and consumes 100% of cpu…

In some examples it stucks at CUT_DEVICE_INIT();

I tried to run simpleCUBLAS example for 20 minutes and nothing happened…

I’m using Ubuntu 7.10, NVIDIA Driver 169.09 and CUDA toolkit 1.1 , and I tried with the 169.12 Driver with the same problems…

Any clues??

Thanks

Rafael Sachetto

sorry to say I think the problem is with having only 128MB memory. 256MB seems to be the minimum required.

Strange because on this page: http://www.nvidia.com/object/geforce_8400M.html it says that my video card (8400M G) has at maximum 256Mb.

I think that means it comes in different configurations up to 256MB.

I’ll take a look at possibly doing something for 128MB systems after we get CUDA 2.0 into production. I’ve heard it worked better on CUDA 1.0, so you might want to try that for now.

Also curious to see if somehow the new beta CUDA 2.0 (just posted) is better or worse. We simply don’t test it on anything less than 256MB. So maybe someone will try. For now only RHEL4 and RHEL5 distros are available in beta.

It works with cuda 1.0

Thanks