Cleanup tool

I used omniverse luncher on ubunto as admin, now when i run isaac sim I have INTERNAL_ERROR in local host 8080. I tried to use cleanup tool to let Omniverse Launcher back into a clean slate. I download cleanup tool for linux but the folder does not have “launcher-cleanup.exe” !
How can I solve my problem?


First, close all Omnivers apps and the Omniverse Launcher (Click the “user” icon then select exit)

Download the cleanup tool here:

Then unpack it and run:

sudo ./launcher-cleanup

Thank you, It works for cleanup, but I still have INTERNAL_ERROR in local host 8080 and also I can not connect Omniverse to server in localhost.

Hi, please share the Isaac Sim logs. Are you able to access http://localhost:8080/?
Are all services green on http://localhost:3080/?

Hi, Yes I have access to both localhosts.

But in localhost 8080 I can only see the users.

That looks OK. It is just missing the /Isaac folder. See this post for the new mount URL:

Instructions to add a mount: 6. Setup FAQ — Omniverse Robotics documentation

it has already exist and I am not able to unmount the previous Isaac folder, I see it on the isaac but it does not shown in localhost 8080.

I created a new connection but it has the same problem.

Try right-clicking localhost in Isaac Sim then click remove. Next add the localhost connection again.

it does not work. I did it but for all new connections, there is already exist a locked Isaac folder. and in localhost 8080 nothing shows except users and still has INTERNAL_ERROR.

Please see this page: Cleanup-Tool — Omniverse Launcher documentation
You will be prompted to delete all Nucleus data.
You should also verify that all folders below are deleted before installing the Launcher again.


Thank you @Sheikh_Dawood , my problem has solved.

1 Like

INTERNAL_ERROR returned again!
Is it possible that this error is because of omniverse outage?

Probably. Please try updating the Cache and Nucleus on the Launcher. There was an update that was pushed out today.

Log out and back in to the Launcher if you are not able to download it.

1 Like

I did everything that you said. I found that the problem occures when I mount Isaac folder to update assets inside it. If I use “create” new Isaac folder, it does not have problem but using “mount” makes the INTERNAL_ERROR. but using create folder itself has another error. It needs new version of assets.

I found that Search_Service in localhost:3080 is not running .

Please see this post to use the new url for the mount.

The Search Service error is a known issue but should not affect the normal use of the Nucleus server.

I have typed ‘sudo ./launcher-cleanup’ in terminal and it said ‘command not found’. How can I do?

Have you downloaded and extracted the files from launcher-cleanup@1.0.0.linux-x86_64.7z?
The launcher-cleanup file is in the downloaded package.

Yes, I successfully do it now. Thanks.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.