Compatibility of jetpack-stats and jetpack

I am using Jetson Orin Nano Developer Kit.
When I run jetson_release, I get the following message.

Software part of jetson-stats 4.2.3 - (c) 2023, Raffaello Bonghi
Jetpack missing!

  • Model: NVIDIA Jetson Orin Nano Developer Kit
  • L4T: 36.2.0
    NV Power Mode[0]: 15W
    Serial Number: [XXX Show with: jetson_release -s XXX]
    Hardware: [XXX] Module: Check with sudo
  • Module: Check with sudo
    Platform: [XXX] Hardware: Module: Check with sudo
  • Distribution: Ubuntu 22.04 Jammy Jellyfish
  • Release: 5.15.122-tegra
    jtop: jtop
  • Version: 4.2.3
  • Service: Inactive
    Libraries: CUDA: 12.2.140
  • CUDA: 12.2.140
  • cuDNN: 8.9.4.25
  • TensorRT: 6.0
  • VPI: 3.0.10
  • Vulkan: 1.3.204
  • OpenCV: 4.8.0 - with CUDA: NO

I ran nvidia-jetpack and got the following

Package: nvidia-jetpack
Version: 6.0-b52
Priority: standard
Section: metapackages
Maintainer: NVIDIA Corporation
Installed-Size: 199 kB
Depends: nvidia-jetpack-runtime (= 6.0-b52), nvidia-jetpack-dev (= 6.0-b52)
Homepage: http://developer.nvidia.com/jetson
Download-Size: 29.3 kB
APT-Manual-Installed: yes
APT-Sources: https://repo.download.nvidia.com/jetson/common r36.2/main arm64 Packages
Description: NVIDIA Jetpack Meta Package

jetpack is installed, but I can’t start jetson-stats, is it because the jetson-stats module is incompatible with Jetpack?
The version of jetson-stats is 4.2.3 and the version of jetpack is 6.0.

Thank you in advance.

Translated with DeepL.com (free version)

Hi @gecreative.kasa, I don’t believe that jetson_stats/jtop has been updated for JetPack 6.0 yet, but that @rbonghi plans to in the near future.

Thank you for your response.

Hi @gecreative.kasa
I will fix it soon, hopefully for this Christmas holiday. (It’s a personal project and I didn’t have time to work on it previously)

Yes, you can download the latest version of jetson-stats 4.2.4 directly from:

sudo pip3 install -U jetson-stats

Release note: Release ⛵ Jetpack 6 onboard! · rbonghi/jetson_stats · GitHub
Documentation: jetson-stats 4.2.4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.